627
Configuring QoS
Configuring QoS
Creating a Parent Policy Map
Beginning in privileged EXEC mode, follow these steps to create a parent policy map and attach it to an interface:
Attaching a Parent Policy Map to an Interface
Beginning in privileged EXEC mode, follow these steps to create attach the parent policy map to an interface:
This is an example of using multiple parent classes to classify matching criteria for voice and video on customer VLANs.
Switch(config)#
class-map match-any video
Switch(config-cmap)#
match ip dscp af41
Switch(config-cmap)#
exit
Switch(config)#
class-map match-any voice
Switch(config-cmap)#
match ip dscp ef
Switch(config-cmap)#
exit
Switch(config)#
class-map match-any customer1-vlan
Switch(config-cmap)#
match vlan 100-105
Switch(config-cmap)#
exit
Switch(config)#
class-map match-any customer2-vlan
Switch(config-cmap)#
match vlan 110-120
Command
Purpose
1.
configure terminal
Enter global configuration mode.
2.
policy-map
parent-policy-map-name
Create a parent policy map by entering the policy map name, and enter
policy-map configuration mode.
3.
class
parent-class-map-name
Enter the parent class-map name, and enter policy-map class
configuration mode.
4.
service policy
child-policy-map-name
Associate the child policy map with the parent policy map
5.
end
Return to privileged EXEC mode.
6.
show policy-map
[
parent-policy-map-name
[
class
class-map-name
]]
Verify your entries.
7.
copy running-config startup-config
(Optional) Save your entries in the configuration file.
Command
Purpose
1.
configure terminal
Enter global configuration mode.
2.
interface
interface-id
Enter interface configuration mode for the interface to which you want to
attach the policy.
3.
switchport mode trunk
Configure the port as a trunk port.
4.
switchport trunk allowed vlan
vlan-list
(Recommended) Restrict VLAN membership for trunk ports to avoid
overlapping VLAN membership if the per-port, per-VLAN policy includes
Layer 3 classification.
5.
service-policy input
parent-
policy-map-name
Attach the parent policy map (created in the previous section) to the
ingress interface.
6.
end
Return to privileged EXEC mode.
7.
show policy-map interface
[
interface-id
]
Verify your entries.
8.
copy running-config startup-config
(Optional) Save your entries in the configuration file.
Summary of Contents for IE 4000
Page 12: ...8 Configuration Overview Default Settings After Initial Switch Configuration ...
Page 52: ...48 Configuring Interfaces Monitoring and Maintaining the Interfaces ...
Page 108: ...104 Configuring Switch Clusters Additional References ...
Page 128: ...124 Performing Switch Administration Additional References ...
Page 130: ...126 Configuring PTP ...
Page 140: ...136 Configuring CIP Additional References ...
Page 146: ...142 Configuring SDM Templates Configuration Examples for Configuring SDM Templates ...
Page 192: ...188 Configuring Switch Based Authentication Additional References ...
Page 244: ...240 Configuring IEEE 802 1x Port Based Authentication Additional References ...
Page 298: ...294 Configuring VLANs Additional References ...
Page 336: ...332 Configuring STP Additional References ...
Page 408: ...404 Configuring DHCP Additional References ...
Page 450: ...446 Configuring IGMP Snooping and MVR Additional References ...
Page 490: ...486 Configuring SPAN and RSPAN Additional References ...
Page 502: ...498 Configuring Layer 2 NAT ...
Page 770: ...766 Configuring IPv6 MLD Snooping Related Documents ...
Page 930: ...926 Configuring IP Unicast Routing Related Documents ...
Page 976: ...972 Configuring Cisco IOS IP SLAs Operations Additional References ...
Page 978: ...974 Dying Gasp ...
Page 990: ...986 Configuring Enhanced Object Tracking Monitoring Enhanced Object Tracking ...
Page 994: ...990 Configuring MODBUS TCP Displaying MODBUS TCP Information ...
Page 996: ...992 Ethernet CFM ...
Page 1066: ...1062 Using an SD Card SD Card Alarms ...