628
Configuring QoS
Configuring QoS
Switch(config-cmap)#
exit
Switch(config)#
policy-map child-policy-1
Switch(config-pmap)#
class voice
Switch(config-pmap-c)#
police cir 10000000 bc 50000
Switch(config-pmap-c-police)#
conform-action set-cos-transmit 5
Switch(config-pmap-c-police)#
exceed-action drop
Switch(config-pmap-c-police)#
exit
Switch(config-pmap-c)#
exit
Switch(config-pmap)#
class video
Switch(config-pmap-c)#
set cos 4
Switch(config-pmap-c)#
exit
Switch(config-pmap)#
class class-default
Switch(config-pmap-c)#
set cos 0
Switch(config-pmap-c)#
exit
Switch(config)#
policy-map child-policy-2
Switch(config-pmap)#
class voice
Switch(config-pmap-c)#
police cir 5000000
Switch(config-pmap-c-police)#
conform-action set-cos-transmit 5
Switch(config-pmap-c-police)#
exceed-action drop
Switch(config-pmap-c-police)#
exit
Switch(config-pmap-c)#
exit
Switch(config-pmap)#
class video
Switch(config-pmap-c)#
police cir 40000000
Switch(config-pmap-c-police)#
conform-action set-cos-transmit 4
Switch(config-pmap-c-police)#
exceed-action set-cos-transmit 1
Switch(config-pmap-c-police)#
exit
Switch(config-pmap-c)#
exit
Switch(config-pmap)#
class class-default
Switch(config-pmap-c)#
set cos 0
Switch(config-pmap-c)#
exit
Switch(config)#
policy-map uni-parent
Switch(config-pmap)#
class customer1-vlan
Switch(config-pmap-c)#
service-policy child-policy-1
Switch(config-pmap-c)#
exit
Switch(config-pmap)#
class customer2-vlan
Switch(config-pmap-c)#
service-policy child-policy-2
Switch(config-pmap-c)#
exit
Switch(config)#
interface fastethernet0/1
Switch(config-if)#
switchport mode trunk
Switch(config-if)#
switchport trunk allowed vlan 100-105, 110-120
Switch(config-if)#
service-policy input uni-parent
Switch(config-pmap-c)#
exit
Configuring Output Policy Maps
You use output policy maps to manage congestion avoidance, queuing, and scheduling of packets leaving the switch.
The switch has four egress queues, and you use output policy maps to control the queue traffic. You configure shaping,
queue-limit, and bandwidth on these queues. You can use high priority (class-based priority queuing). Policing is not
supported on output policy maps, except when configuring priority with police for class-based priority queuing. Output
policy map classification criteria are matching a CoS, DSCP, or IP precedence value or a QoS group.
Follow these guidelines when configuring output policy maps on physical ports:
You can configure and attach as many output policy maps as there are ports on the switch. Multiple output policy
maps can use the same queue-limit configuration. However, these policy maps can have only three unique
queue-limit configurations.
Output policy maps can have a maximum of four classes, including the class
class-default
.
Summary of Contents for IE 4000
Page 12: ...8 Configuration Overview Default Settings After Initial Switch Configuration ...
Page 52: ...48 Configuring Interfaces Monitoring and Maintaining the Interfaces ...
Page 108: ...104 Configuring Switch Clusters Additional References ...
Page 128: ...124 Performing Switch Administration Additional References ...
Page 130: ...126 Configuring PTP ...
Page 140: ...136 Configuring CIP Additional References ...
Page 146: ...142 Configuring SDM Templates Configuration Examples for Configuring SDM Templates ...
Page 192: ...188 Configuring Switch Based Authentication Additional References ...
Page 244: ...240 Configuring IEEE 802 1x Port Based Authentication Additional References ...
Page 298: ...294 Configuring VLANs Additional References ...
Page 336: ...332 Configuring STP Additional References ...
Page 408: ...404 Configuring DHCP Additional References ...
Page 450: ...446 Configuring IGMP Snooping and MVR Additional References ...
Page 490: ...486 Configuring SPAN and RSPAN Additional References ...
Page 502: ...498 Configuring Layer 2 NAT ...
Page 770: ...766 Configuring IPv6 MLD Snooping Related Documents ...
Page 930: ...926 Configuring IP Unicast Routing Related Documents ...
Page 976: ...972 Configuring Cisco IOS IP SLAs Operations Additional References ...
Page 978: ...974 Dying Gasp ...
Page 990: ...986 Configuring Enhanced Object Tracking Monitoring Enhanced Object Tracking ...
Page 994: ...990 Configuring MODBUS TCP Displaying MODBUS TCP Information ...
Page 996: ...992 Ethernet CFM ...
Page 1066: ...1062 Using an SD Card SD Card Alarms ...