426
SwitchA#config
SwitchA(config)# interface vlan 1
SwitchA(Config-if-Vlan1)# ip address 10.1.1.1 255.255.255.0
SwitchA (config-if-Vlan1)#
Configure the IP address of interface vlan 2
SwitchA (config)# vlan 2
SwitchA (Config-Vlan2)# switchport interface ethernet 1/2
Set the port Ethernet1/2 access vlan 2 successfully
SwitchA (Config-Vlan2)# exit
SwitchA (Config)# interface vlan 2
SwitchA (Config-if-Vlan2)# ip address 20.1.1.1 255.255.255.0
Initiate RIP protocol and configure the RIP segments
SwitchA(config)#router rip
SwitchA(config-router)#network vlan 1
SwitchA(config-router)#network vlan 2
SwitchA(config-router)#exit
Configure that the interface vlan 2 do not transmit RIP messages to SwitchC
SwitchA(config)#router rip
SwitchA(config-router)#passive-interface vlan 2
SwitchA(config-router)#exit
SwitchA (config) #
b) Layer 3 switch SwitchB
Configure the IP address of interface vlan 1
SwitchB#config
SwitchB(config)# interface vlan 1
SwitchB(Config-if-Vlan1)# ip address 10.1.1.2 255.255.255.0
SwitchB (Config-if-Vlan1)exit
Initiate RIP protocol and configure the RIP segments
SwitchB(config)#router rip
SwitchB(config-router)#network vlan 1
SwitchB(config-router)#exit
c) Layer 3 switch SwitchC
SwitchC#config
SwitchC(config)# interface vlan 1
Configure the IP address of interface vlan 1
SwitchC(Config-if-Vlan1)# ip address 20.1.1.2 255.255.255.0
SwitchC (Config-if-Vlan1)#exit
Initiate RIP protocol and configure the RIP segments
SwitchC(config)#router rip