! Configure VPLS instance vplsA.
host2(config)#
bridge vplsA vpls transport-virtual-router default
!
! Configure VPLS instance vplsB.
host2(config)#
bridge vplsB vpls transport-virtual-router default
!
! Configure Fast Ethernet interface 2/5 between PE 2 and CE 3,
! and assign it to vplsA as a trunk interface.
host2(config)#
interface fastEthernet 2/5
host2(config-if)#
bridge-group vplsA subscriber-trunk
host2(config-if)#
exit
!
! Configure bridged Ethernet interface 6/0.21 between PE 2 and CE 4,
! and assign it to vplsB as a trunk interface.
host2(config)#
interface atm 6/0.21 point-to-point
host2(config-subif)#
atm pvc 21 0 21 aal5snap 0 0 0
host2(config-subif)#
encapsulation bridge1483 mac-address 0090.1a40.9992
host2(config-subif)#
bridge-group vplsB subscriber-trunk
host2(config-if)#
exit
!
! Configure LDP signaling for vplsA.
host2(config)#
mpls ldp vpls vplsA vpls-id 1
host2(config)#
mpls ldp vpls vplsA neighbor 1.1.1.1
!
! Configure LDP signaling for vplsB.
host2(config)#
mpls ldp vpls vplsB vpls-id 2
host2(config)#
mpls ldp vpls vplsB neighbor 1.1.1.1
!
! Configure a loopback interface on PE 2 and assign it an IP address.
host2(config)#
interface loopback 0
host2(config-if)#
ip address 2.2.2.2 255.255.255.255
host2(config-if)#
exit
!
! Assign the router ID for PE 2 using the IP address of the loopback interface.
host2(config)#
ip router-id 2.2.2.2
!
! Configure ATM core-facing interface 6/1.20 between PE 2 and the P router,
! and assign it an IP address.
host2(config)#
interface atm 6/1.20 point-to-point
host2(config-subif)#
atm pvc 20 0 20 aal5snap 0 0 0
host2(config-subif)#
ip address 20.20.20.2 255.255.255.0
!
! Enable MPLS, LDP, and topology-driven LSPs on the core-facing interface.
host2(config-subif)#
mpls
host2(config-subif)#
mpls ldp
host2(config-subif)#
exit
!
! Configure OSPF routing in the core MPLS network.
host2(config)#
router ospf 1
host2(config-router)#
network 2.2.2.2 0.0.0.0 area 0.0.0.0
host2(config-router)#
network 20.20.20.0 0.0.0.255 area 0.0.0.0
host2(config-router)#
exit
Related Topics
■
Configuration Tasks for VPLS with LDP Signaling on page 599
VPLS Configuration Example with LDP Signaling
■
605
Chapter 10: Configuring VPLS
Summary of Contents for JUNOSE
Page 6: ...vi...
Page 8: ...viii JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 24: ...xxiv Table of Contents JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 37: ...Part 1 Border Gateway Protocol Configuring BGP Routing on page 3 Border Gateway Protocol 1...
Page 38: ...2 Border Gateway Protocol JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 234: ...198 Monitoring BGP JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 236: ...200 Multiprotocol Layer Switching JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 298: ...262 Point to Multipoint LSPs Configuration JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 536: ...500 Monitoring BGP MPLS VPNs JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 538: ...502 Layer 2 Services Over MPLS JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 604: ...568 Virtual Private LAN Service JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 618: ...582 VPLS References JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 674: ...638 Virtual Private Wire Service JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 718: ...682 Monitoring MPLS Forwarding Table for VPWS JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Page 719: ...Part 6 Index Index on page 685 Index 683...
Page 720: ...684 Index JUNOSe 11 0 x BGP and MPLS Configuration Guide...