1-9
Cisco ASA Series CLI Configuration Guide
Chapter 1 Completing Interface Configuration (Routed Mode)
Completing Interface Configuration in Routed Mode
Example
The following example configures parameters for VLAN 101:
hostname(config)#
interface vlan 101
hostname(config-if)#
nameif inside
hostname(config-if)#
security-level 100
hostname(config-if)#
ip address 10.1.1.1 255.255.255.0
The following example configures parameters in multiple context mode for the context configuration.
The interface ID is a mapped name.
hostname/contextA(config)#
interface int1
ip address
ip_address
[
mask
] [
standby
ip_address
]
Example:
hostname(config-if)# ip address 10.1.1.1
255.255.255.0 standby 10.1.1.2
Sets the IP address manually.
Note
For use with failover, you must set the IP address and
standby address manually; DHCP and PPPoE are not
supported.
The
ip_address
and
mask
arguments set the interface IP address
and subnet mask.
The
standby
ip_address
argument is used for failover. See the
“Configuring Active/Standby Failover” section on page 1-7
or the
“Configuring Active/Active Failover” section on page 1-9
more information.
ip address dhcp
[
setroute
]
Example:
hostname(config-if)# ip address dhcp
Obtains an IP address from a DHCP server.
The
setroute
keyword lets the ASA use the default route supplied
by the DHCP server.
Reenter this command to reset the DHCP lease and request a new
lease.
If you do not enable the interface using the
no shutdown
command before you enter the
ip address dhcp
command, some
DHCP requests might not be sent.
To obtain an IP address from a PPPoE server, see
Chapter 1, “Configuring the PPPoE Client.”
PPPoE is not supported in multiple context mode.
Step 4
security-level
number
Example:
hostname(config-if)# security-level 50
Sets the security level, where
number
is an integer between 0
(lowest) and 100 (highest). See the
Step 5
(Optional)
management-only
Example:
hostname(config-if)# management-only
Sets an interface to management-only mode so that it does not
pass through traffic.
By default, Management interfaces are configured as
management-only. To disable this setting, enter the
no
management-only
command.
(ASA 5512-X through ASA 5555-X) You cannot disable
management-only
on the Management 0/0 interface.
The
management-only
command
is not supported for a
redundant interface.
Command
Purpose
Summary of Contents for 5505 - ASA Firewall Edition Bundle
Page 28: ...Glossary GL 24 Cisco ASA Series CLI Configuration Guide ...
Page 61: ...P A R T 1 Getting Started with the ASA ...
Page 62: ......
Page 219: ...P A R T 2 Configuring High Availability and Scalability ...
Page 220: ......
Page 403: ...P A R T 2 Configuring Interfaces ...
Page 404: ......
Page 499: ...P A R T 2 Configuring Basic Settings ...
Page 500: ......
Page 533: ...P A R T 2 Configuring Objects and Access Lists ...
Page 534: ......
Page 601: ...P A R T 2 Configuring IP Routing ...
Page 602: ......
Page 745: ...P A R T 2 Configuring Network Address Translation ...
Page 746: ......
Page 845: ...P A R T 2 Configuring AAA Servers and the Local Database ...
Page 846: ......
Page 981: ...P A R T 2 Configuring Access Control ...
Page 982: ......
Page 1061: ...P A R T 2 Configuring Service Policies Using the Modular Policy Framework ...
Page 1062: ......
Page 1093: ...P A R T 2 Configuring Application Inspection ...
Page 1094: ......
Page 1191: ...P A R T 2 Configuring Unified Communications ...
Page 1192: ......
Page 1333: ...P A R T 2 Configuring Connection Settings and QoS ...
Page 1334: ......
Page 1379: ...P A R T 2 Configuring Advanced Network Protection ...
Page 1380: ......
Page 1475: ...P A R T 2 Configuring Modules ...
Page 1476: ......
Page 1549: ...P A R T 2 Configuring VPN ...
Page 1550: ......
Page 1965: ...P A R T 2 Configuring Logging SNMP and Smart Call Home ...
Page 1966: ......
Page 2059: ...P A R T 2 System Administration ...
Page 2060: ......
Page 2098: ...1 8 Cisco ASA Series CLI Configuration Guide Chapter 1 Troubleshooting Viewing the Coredump ...
Page 2099: ...P A R T 2 Reference ...
Page 2100: ......