428
SwitchA(config)#
SwitchA(config)#router rip
SwitchA(config-router)#address-family ipv4 vrf vpnb
SwitchA(config-router-af)#redistribute bgp
SwitchA(config-router-af)#network Vlan1
SwitchA(config-router-af)#exit-address-family
SwitchA(config-router)#address-family ipv4 vrf vpnc
SwitchA(config-router-af)#redistribute bgp
SwitchA(config-router-af)#network Vlan2
SwitchA(config-router-af)#exit-address-family
SwitchA(config-router)#
b) CE1 Layer 3 switch SwitchB
configure the IP address of Ethernet port E 1/2
SwitchB#config
SwitchB(config)# interface Vlan1
SwitchB(config-if-Vlan1)# ip address 10.1.1.2 255.255.255.0
SwitchB (config-if-Vlan1)exit
Initiate RIP protocol and configure the RIP segments
SwitchB(config)#router rip
SwitchB(config-router-rip)#network Vlan1
SwitchB(config-router-rip)#exit
c) CE2 Layer 3 switch SwitchC
Configure the IP address of Ethernet port E 1/2
SwitchC#config
SwitchC(config)# interface Vlan1
SwitchC(config-if-vlan1)# ip address 20.1.1.2 255.255.255.0
SwitchC (config-if-vlan1)#exit
Initiate RIP protocol and configure the RIP segments
SwitchC(config)#router rip
SwitchC(config-router)#network Vlan1
SwitchC(config-router)#exit
14.4.5 Troubleshooting Help Of RIP
The RIP protocol may not be working properly due to errors such as physical
connection, configuration error when configuring and using the RIP protocol. So users
should pay attention to following:
First ensure the physic connection is correct
Second, ensure the interface and chain protocol are UP (use show interface