83-18
Catalyst 4500 Series Switch, Cisco IOS Software Configuration Guide - Cisco IOS XE 3.9.xE and IOS 15.2(5)Ex
Chapter 83 Configuring Easy Virtual Network
Configuration Examples for Configuring EVN
exit-address-family
interface Eth0/0
no shutddown
vnet trunk
ip add 1.1.1.1 255.255.255.0
Switch(config-if)#int eth0/0
Switch(config-if)#vnet name vRED
Switch(config-if-vnet)# ip address 100.1.1.1 255.255.255.0
Switch(config-if-vnet)#do show ip interface brief
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 1.1.1.1 YES manual up up
Ethernet0/0.131 100.1.1.1 YES manual up up
Ethernet0/0.132 1.1.1.1 YES manual up up
Switch(config)#int eth0/0
Switch(config-if)#vnet name vBLUE
Switch(config-if-vnet)#ip address 101.1.1.1 255.255.255.0
Switch(config-if-vnet)#do show ip interface brief
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 1.1.1.1 YES manual up up
Ethernet0/0.131 100.1.1.1 YES manual up up
Ethernet0/0.132 101.1.1.1 YES manual up up
Configuration Examples for Configuring EVN
Example: Virtual Networks Using OSPF with network Commands
In this example, network commands associate a shared VRF interface with a base VRF and two named
VRFs, red and blue. There are three OSPF instances because each VRF needs its own OSPF instance.
OSPF 1 has no VRF, so it is vnet global.
vrf definition red
vnet tag 100
address-family ipv4
exit-address-family
!
vrf definition blue
vnet tag 200
address-family ipv4
exit-address-family
!
interface gigabitethernet 0/0/0
ip address 10.0.0.1 255.255.255.0
vnet trunk
vnet name red
ip ospf cost 100
!
router ospf 1
log-adjacency-changes detail
network 10.0.0.0 255.255.255.0 area 0
router ospf 2 vrf red
log-adjacency-changes
network 10.0.0.0 255.255.255.0 area 0
router ospf 3 vrf blue
log-adjacency-changes
Summary of Contents for Catalyst 4500 Series
Page 2: ......
Page 4: ......
Page 2086: ...Index IN 46 Software Configuration Guide Release IOS XE 3 9 0E and IOS 15 2 5 E ...