42-21
Cisco 7600 Series Router Cisco IOS Software Configuration Guide, Release 12.2SX
OL-4266-08
Chapter 42 Configuring PFC3BXL or PFC3B Mode MPLS QoS
Configuring PFC3BXL or PFC3B Mode MPLS QoS
This example shows that all packets that contain MPLS experimental value 3 are matched by the traffic
class named exp3:
Router#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
class-map exp3
Router(config-cmap)#
match mpls experimental topmost 3
Router(config-cmap)#
exit
Router(config)#
policy-map exp3
Router(config-pmap)#
class exp3
Router(config-pmap-c)#
police 1000000 8000000 conform-action transmit exceed-action drop
Router(config-pmap-c)#
exit
Router(config-pmap)#
end
Router#
show class exp3
Class Map match-all exp3 (id 61)
Match mpls experimental topmost 3
Router#
show policy-map exp3
Policy Map exp3
Class exp3
police cir 1000000 bc 8000000 be 8000000 conform-action transmit exceed-action drop
Router#
show running-config interface fastethernet 3/27
Building configuration...
Current configuration : 173 bytes
!
interface FastEthernet3/27
ip address 47.0.0.1 255.0.0.0
tag-switching ip
end
Router#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
interface fastethernet 3/27
Router(config-if)#
service-policy input exp3
Router(config-if)#
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router#
show running-config interface fastethernet 3/27
Building configuration...
Current configuration : 173 bytes
!
interface FastEthernet3/27
ip address 47.0.0.1 255.0.0.0
tag-switching ip
service-policy input exp3
end
Router#
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router#
show mls qos mpls
QoS Summary [MPLS]: (* - shared aggregates, Mod - switch module)
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In exp3 0 2 dscp 0 0 0
All 5 - Default 0 0* No 0 3466140423 0
Router#
show policy-map interface fastethernet 3/27
FastEthernet3/27
Service-policy input: exp3