host1(config)#
virtual-router pe1
host1:pe1(config)#
router bgp 100
host1:pe1(config-router)#
neighbor 10.4.4.4 remote-as 200
host1:pe1(config-router)#
neighbor 10.4.4.4 ebgp-multihop
host1:pe1(config-router)#
neighbor 10.4.4.4 update-source loopback1
host1:pe1(config-router)#
exit
On host 2, VR CE 1:
host2(config)#
virtual-router ce1
host2:ce1(config)#
interface loopback 1
host2:ce1(config-if)#
ip address 10.4.4.4 255.255.255.255
host2:ce1(config-if)#
exit
host2:ce1(config)#
ip route 10.2.2.2 255.255.255.255 atm2/1.1
host2:ce1(config)#
router bgp 200
host2:ce1(config-router)#
neighbor 10.2.2.2 remote-as 100
host2:ce1(config-router)#
neighbor 10.2.2.2 ebgp-multihop
host2:ce1(config-router)#
neighbor 10.2.2.2 update-source loopback1
host2:ce1(config-router)#
exit
You must also configure either fallback global or a default route to a manually created
shared interface in the VRF. See “Configuring a Fallback Global Option” on page 463 or
“Configuring a Default Route to a Shared Interface” on page 462 for details.
You can use the BGP session between the CE router and the parent VR to enable the CE
router to advertise prefixes within the VPN site that can be reachable from the global
Internet. An alternative configuration is to use a global export map as described in “Setting
Import and Export Maps for a VRF” on page 428.
Enabling Traffic Flow from the Internet to the VPN
When traffic flows from the Internet to a VPN, the traffic arrives at the PE router on an
interface in the global context. BGP performs a lookup in the global IP routing table,
which normally does not contain VPN routes. You can use one of the following methods
to advertise public VPN routes to the Internet (get the routes into the global routing table)
and thus enable traffic flow from the Internet to those VPNS.
•
Manually create shared interfaces in the parent VR and manually add static routes to
those shared interfaces. See “Enabling VRF–to–VR Peering” on page 454 for more
information.
•
Export VPN routes to the global BGP RIB. See “Setting Import and Export Maps for a
VRF” on page 428.
Static Routes to a Shared IP Interface
You can introduce routes to VPN sites into the global routing table by placing static routes
to the VPN sites into the global table. The static routes must point to shared IP interfaces
that are shares of the PE-CE interface for each particular VPN site. The static routes must
then be injected into BGP (possibly as part of an aggregate) so that they can be reached
from the Internet. Figure 105 on page 468 illustrates this approach:
467
Copyright © 2010, Juniper Networks, Inc.
Chapter 6: Configuring BGP-MPLS Applications
Summary of Contents for JUNOSE 11.2.X BGP AND MPLS
Page 6: ...Copyright 2010 Juniper Networks Inc vi...
Page 8: ...Copyright 2010 Juniper Networks Inc viii JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 38: ...Copyright 2010 Juniper Networks Inc 2 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 192: ...Copyright 2010 Juniper Networks Inc 156 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 242: ...Copyright 2010 Juniper Networks Inc 206 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 244: ...Copyright 2010 Juniper Networks Inc 208 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 310: ...Copyright 2010 Juniper Networks Inc 274 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 356: ...Copyright 2010 Juniper Networks Inc 320 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 418: ...Copyright 2010 Juniper Networks Inc 382 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 524: ...Copyright 2010 Juniper Networks Inc 488 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 544: ...Copyright 2010 Juniper Networks Inc 508 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 608: ...Copyright 2010 Juniper Networks Inc 572 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 672: ...Copyright 2010 Juniper Networks Inc 636 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 674: ...Copyright 2010 Juniper Networks Inc 638 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 716: ...Copyright 2010 Juniper Networks Inc 680 JunosE 11 2 x BGP and MPLS Configuration Guide...
Page 717: ...PART 6 Index Index on page 683 681 Copyright 2010 Juniper Networks Inc...
Page 718: ...Copyright 2010 Juniper Networks Inc 682 JunosE 11 2 x BGP and MPLS Configuration Guide...