! matches the route target configured for l2vpnB on PE 1.
host2(config)#
l2vpn l2vpnB encapsulation-type ethernet
host2(config)#
l2vpn l2vpnB site-range 20
host2(config)#
l2vpn l2vpnB site-name chicago site-id 4
host2(config)#
l2vpn l2vpnB rd 100:12
host2(config)#
l2vpn l2vpnB route-target both 100:2
host2(config)#
l2vpn l2vpnB control-word
host2(config)#
l2vpn l2vpnB sequencing
!
! Configure the customer-facing interface between PE 2 and CE 3
! in L2VPN instance l2vpnA.
host2(config)#
interface fastEthernet 3/5
host2(config-if)#
l2vpn l2vpnA local-site-id 3 remote-site-id 1
host2(config-if)#
exit
!
! Configure the customer-facing interface between PE 2 and CE 4
! in L2VPN instance l2vpnB.
host2(config)#
interface gigabitEthernet 0/1
host2(config-subif)#
l2vpn l2vpnB local-site-id 4 remote-site-id 2
host2(config-if)#
exit
!
! Configure a loopback interface on PE 2 and assign it an IP address.
host2(config)#
interface loopback 0
host2(config-if)#
ip address 10.2.2.2 255.255.255.255
host2(config-if)#
exit
!
! Assign the router ID for PE 2 using the IP address of the loopback interface.
host2(config)#
ip router-id 10.2.2.2
!
! Configure BGP signaling.
host2(config)#
router bgp 738
host2(config-router)#
neighbor 10.2.2.2 remote-as 738
host2(config-router)#
neighbor 10.2.2.2 update-source loopback 0
host2(config-router)#
neighbor 10.2.2.2 next-hop-self
host2(config-router)#
address-family l2vpn signaling
host2(config-router-af)#
neighbor 10.2.2.2 activate
host2(config-router-af)#
neighbor 10.2.2.2 next-hop-self
host2(config-router)#
address-family vpws l2vpnA
host2(config-router-af)#
exit-address-family
host2(config-router)#
address-family vpws l2vpnB
host2(config-router-af)#
exit-address-family
!
! Enable MPLS on the default virtual router.
host2(config)#
mpls
!
! Configure ATM core-facing interface 3/1.100 between PE 2 and the P router,
! and assign it an IP address.
host2(config)#
interface atm 3/1.100 point-to-point
host2(config-subif)#
atm pvc 100 1 100 aal5snap 0 0 0
host2(config-subif)#
ip address 192.168.4.4 255.255.255.0
!
! Enable MPLS, LDP, and topology-driven LSPs on the on the core-facing interface.
host2(config-subif)#
mpls
host2(config-subif)#
mpls ldp
host2(config-subif)#
exit
!
VPWS Configuration Example
■
663
Chapter 13: Configuring VPWS
Содержание JUNOSE
Страница 6: ...vi...
Страница 8: ...viii JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 24: ...xxiv Table of Contents JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 37: ...Part 1 Border Gateway Protocol Configuring BGP Routing on page 3 Border Gateway Protocol 1...
Страница 38: ...2 Border Gateway Protocol JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 234: ...198 Monitoring BGP JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 236: ...200 Multiprotocol Layer Switching JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 298: ...262 Point to Multipoint LSPs Configuration JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 346: ...310 Example Traffic Class Configuration for Differentiated Services JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 535: ...There is no no version See undebug ip mbgp Monitoring BGP MPLS VPNs 499 Chapter 5 Configuring BGP MPLS Applications...
Страница 536: ...500 Monitoring BGP MPLS VPNs JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 538: ...502 Layer 2 Services Over MPLS JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 592: ...556 Multiple ATM Virtual Circuits over a Single Pseudowire Example JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 604: ...568 Virtual Private LAN Service JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 618: ...582 VPLS References JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 642: ...606 VPLS Configuration Example with LDP Signaling JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 674: ...638 Virtual Private Wire Service JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 718: ...682 Monitoring MPLS Forwarding Table for VPWS JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 719: ...Part 6 Index Index on page 685 Index 683...
Страница 720: ...684 Index JUNOSe 11 0 x BGP and MPLS Configuration Guide...