! Assign the router ID for PE 2 using the IP address of the loopback interface.
host2(config)#
ip router-id 10.2.2.2
!
! Enable MPLS on the default virtual router.
host2(config)#
mpls
!
! Configure ATM core-facing interface 3/1.100 between PE 2 and the P router,
! and assign it an IP address.
host2(config)#
interface atm 3/1.100 point-to-point
host2(config-subif)#
atm pvc 100 1 100 aal5snap 0 0 0
host2(config-subif)#
ip address 192.168.2.2 255.255.255.0
!
! Enable MPLS, LDP, and topology-driven LSPs on the on the core-facing interface.
host2(config-subif)#
mpls
host2(config-subif)#
mpls ldp
host2(config-subif)#
exit
!
! Configure BGP signaling.
host2(config)#
router bgp 100
host2(config-router)#
neighbor 10.1.1.1 remote-as 100
host2(config-router)#
neighbor 10.1.1.1 update-source loopback 0
host2(config-router)#
neighbor 10.1.1.1 next-hop-self
host2(config-router)#
address-family l2vpn signaling
host2(config-router-af)#
neighbor 10.1.1.1 activate
host2(config-router-af)#
neighbor 10.1.1.1 next-hop-self
host2(config-router-af)#
exit-address-family
host2(config-router)#
address-family vpls vplsA
host2(config-router-af)#
exit-address-family
host2(config-router)#
address-family vpls vplsB
host2(config-router-af)#
exit-address-family
host2(config-router)#
exit
Related Topics
■
Configuration Tasks for VPLS with BGP Signaling on page 584
Configuration Tasks for VPLS with LDP Signaling
To configure VPLS with LDP signaling on the PE router:
1.
Configure a single instance of VPLS, known as a VPLS instance, on the PE router
for each VPLS domain in which the router participates.
2.
(Optional) Configure optional attributes for the VPLS instance.
For instructions, see “Configuring Optional Attributes for VPLS Instances” on
page 587.
3.
Configure network interfaces to connect the PE router to each CE device.
For instructions, see “Configuring VPLS Network Interfaces” on page 588.
4.
(Optional) Configure nondefault subscriber policies for the VPLS network interface.
For instructions, see “Configuring Subscriber Policies for VPLS Network Interfaces”
on page 589.
Configuration Tasks for VPLS with LDP Signaling
■
599
Chapter 10: Configuring VPLS
Содержание JUNOSE
Страница 6: ...vi...
Страница 8: ...viii JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 24: ...xxiv Table of Contents JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 37: ...Part 1 Border Gateway Protocol Configuring BGP Routing on page 3 Border Gateway Protocol 1...
Страница 38: ...2 Border Gateway Protocol JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 234: ...198 Monitoring BGP JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 236: ...200 Multiprotocol Layer Switching JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 298: ...262 Point to Multipoint LSPs Configuration JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 346: ...310 Example Traffic Class Configuration for Differentiated Services JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 535: ...There is no no version See undebug ip mbgp Monitoring BGP MPLS VPNs 499 Chapter 5 Configuring BGP MPLS Applications...
Страница 536: ...500 Monitoring BGP MPLS VPNs JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 538: ...502 Layer 2 Services Over MPLS JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 592: ...556 Multiple ATM Virtual Circuits over a Single Pseudowire Example JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 604: ...568 Virtual Private LAN Service JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 618: ...582 VPLS References JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 642: ...606 VPLS Configuration Example with LDP Signaling JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 674: ...638 Virtual Private Wire Service JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 718: ...682 Monitoring MPLS Forwarding Table for VPWS JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 719: ...Part 6 Index Index on page 685 Index 683...
Страница 720: ...684 Index JUNOSe 11 0 x BGP and MPLS Configuration Guide...