!
! Configure BGP signaling.
host1(config)#
router bgp 100
host1(config-router)#
neighbor 10.2.2.2 remote-as 100
host1(config-router)#
neighbor 10.2.2.2 update-source loopback 0
host1(config-router)#
neighbor 10.2.2.2 next-hop-self
host1(config-router)#
address-family l2vpn signaling
host1(config-router-af)#
neighbor 10.2.2.2 activate
host1(config-router-af)#
neighbor 10.2.2.2 next-hop-self
host1(config-router-af)#
exit-address-family
host1(config-router)#
address-family vpls vplsA
host1(config-router-af)#
exit-address-family
host1(config-router)#
address-family vpls vplsB
host1(config-router-af)#
exit-address-family
host1(config-router)#
exit
Configuration on PE 2 (Remote PE Router)
Use the following commands on the remote PE router (PE 2) to configure the VPLS
topology shown in Figure 129 on page 596.
! Configure VPLS instance vplsA. The route target (100:1)
! matches the route target configured for vplsA on PE 1.
host2(config)#
bridge vplsA vpls transport-virtual-router default
host2(config)#
bridge vplsA vpls site-range 10
host2(config)#
bridge vplsA vpls site-name chicago site-id 2
host2(config)#
bridge vplsA vpls rd 100:21
host2(config)#
bridge vplsA vpls route-target both 100:1
!
! Configure VPLS instance vplsB. The route target (100:2)
! matches the route target configured for vplsB on PE 1.
host2(config)#
bridge vplsB vpls transport-virtual-router default
host2(config)#
bridge vplsB vpls site-range 20
host2(config)#
bridge vplsB vpls site-name chicago site-id 2
host2(config)#
bridge vplsB vpls rd 100:22
host2 (config)#
bridge vplsB vpls route-target both 100:2
! Configure Fast Ethernet interface 3/5 between PE 2 and CE 3,
! and assign it to vplsA as a trunk interface.
host2(config)#
interface fastEthernet 3/5
host2(config-if)#
bridge-group vplsA subscriber-trunk
host2(config-if)#
exit
!
! Configure bridged Ethernet interface 2/0.21 between PE 2 and CE 4,
! and assign it to vplsB as a trunk interface.
host2(config)#
interface atm 2/0.21 point-to-point
host2(config-subif)#
atm pvc 21 0 21 aal5snap 0 0 0
host2(config-subif)#
encapsulation bridge1483 mac-address 0090.1a40.9992
host2(config-subif)#
bridge-group vplsB subscriber-trunk
host2(config-if)#
exit
!
! Configure a loopback interface on PE 2 and assign it an IP address.
host2(config)#
interface loopback 0
host2(config-if)#
ip address 10.2.2.2 255.255.255.255
host2(config-if)#
exit
!
598
■
VPLS Configuration Example with BGP Signaling
JUNOSe 11.0.x BGP and MPLS Configuration Guide
Содержание JUNOSE
Страница 6: ...vi...
Страница 8: ...viii JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 24: ...xxiv Table of Contents JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 37: ...Part 1 Border Gateway Protocol Configuring BGP Routing on page 3 Border Gateway Protocol 1...
Страница 38: ...2 Border Gateway Protocol JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 234: ...198 Monitoring BGP JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 236: ...200 Multiprotocol Layer Switching JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 298: ...262 Point to Multipoint LSPs Configuration JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 346: ...310 Example Traffic Class Configuration for Differentiated Services JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 535: ...There is no no version See undebug ip mbgp Monitoring BGP MPLS VPNs 499 Chapter 5 Configuring BGP MPLS Applications...
Страница 536: ...500 Monitoring BGP MPLS VPNs JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 538: ...502 Layer 2 Services Over MPLS JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 592: ...556 Multiple ATM Virtual Circuits over a Single Pseudowire Example JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 604: ...568 Virtual Private LAN Service JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 618: ...582 VPLS References JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 642: ...606 VPLS Configuration Example with LDP Signaling JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 674: ...638 Virtual Private Wire Service JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 718: ...682 Monitoring MPLS Forwarding Table for VPWS JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 719: ...Part 6 Index Index on page 685 Index 683...
Страница 720: ...684 Index JUNOSe 11 0 x BGP and MPLS Configuration Guide...