host1(config)#
interface gigabitEthernet 1/1
host1(config-subif)#
l2vpn l2vpnB local-site-id 2 remote-site-id 4
host1(config-if)#
exit
!
! Configure a loopback interface on PE 1 and assign it an IP address.
host1(config)#
interface loopback 0
host1(config-if)#
ip address 10.1.1.1 255.255.255.255
host1(config-if)#
exit
!
! Assign the router ID for PE 1 using the IP address of the loopback interface.
host1(config)#
ip router-id 10.3.3.3
!
! Configure BGP signaling.
host1(config)#
router bgp 738
host1(config-router)#
neighbor 10.1.1.1 remote-as 738
host1(config-router)#
neighbor 10.1.1.1 update-source loopback 0
host1(config-router)#
neighbor 10.1.1.1 next-hop-self
host1(config-router)#
address-family l2vpn signaling
host1(config-router-af)#
neighbor 10.1.1.1 activate
host1(config-router-af)#
neighbor 10.1.1.1 next-hop-self
host1(config-router-af)#
exit-address-family
host1(config-router)#
address-family vpws l2vpnA
host1(config-router-af)#
exit-address-family
host1(config-router)#
address-family vpws l2vpnB
host1(config-router-af)#
exit-address-family
!
! Enable MPLS on the default virtual router.
host1(config)#
mpls
! Configure ATM core-facing interface 2/0.100 between PE 1 and the P router,
host1(config)#
interface atm 2/0.100
host1(config-subif)#
atm pvc 100 1 100 aal5snap 0 0 0
! and assign it an IP address.
host1(config-subif)#
ip address 192.168.5.5 255.255.255.0
!
! Enable MPLS, LDP, and topology-driven LSPs on the core-facing interface.
host1(config-subif)#
mpls
host1(config-subif)#
mpls ldp
host1(config-subif)#
exit
Configuration on PE 2 (Remote PE Router)
Use the following commands on the remote PE router (PE 2) to configure the VPWS
topology shown in Figure 134 on page 660.
! Configure VPWS instance l2vpnA. The route target (100:1)
! matches the route target configured for l2vpnA on PE 1.
host2(config)#
l2vpn l2vpnA encapsulation-type ethernet
host2(config)#
l2vpn l2vpnA site-range 10
host2(config)#
l2vpn l2vpnA site-name chicago site-id 3
host2(config)#
l2vpn l2vpnA rd 100:11
host2(config)#
l2vpn l2vpnA route-target both 100:1
host2(config)#
l2vpn l2vpnA control-word
host2(config)#
l2vpn l2vpnA sequencing
!
! Configure VPWS instance l2vpnB. The route target (100:2)
662
■
VPWS Configuration Example
JUNOSe 11.0.x BGP and MPLS Configuration Guide
Содержание JUNOSE
Страница 6: ...vi...
Страница 8: ...viii JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 24: ...xxiv Table of Contents JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 37: ...Part 1 Border Gateway Protocol Configuring BGP Routing on page 3 Border Gateway Protocol 1...
Страница 38: ...2 Border Gateway Protocol JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 234: ...198 Monitoring BGP JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 236: ...200 Multiprotocol Layer Switching JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 298: ...262 Point to Multipoint LSPs Configuration JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 346: ...310 Example Traffic Class Configuration for Differentiated Services JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 535: ...There is no no version See undebug ip mbgp Monitoring BGP MPLS VPNs 499 Chapter 5 Configuring BGP MPLS Applications...
Страница 536: ...500 Monitoring BGP MPLS VPNs JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 538: ...502 Layer 2 Services Over MPLS JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 592: ...556 Multiple ATM Virtual Circuits over a Single Pseudowire Example JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 604: ...568 Virtual Private LAN Service JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 618: ...582 VPLS References JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 642: ...606 VPLS Configuration Example with LDP Signaling JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 674: ...638 Virtual Private Wire Service JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 718: ...682 Monitoring MPLS Forwarding Table for VPWS JUNOSe 11 0 x BGP and MPLS Configuration Guide...
Страница 719: ...Part 6 Index Index on page 685 Index 683...
Страница 720: ...684 Index JUNOSe 11 0 x BGP and MPLS Configuration Guide...