568
Configuring Network Security with ACLs
Configuration Examples for Network Security with ACLs
Switch(config-std-nacl)#
remark Do not allow Jones subnet through
Switch(config-std-nacl)#
deny 171.69.0.0 0.0.255.255
In this example of a named ACL, the Jones subnet is not allowed to use outbound Telnet:
Switch(config)#
ip access-list extended telnetting
Switch(config-ext-nacl)#
remark Do not allow Jones subnet to telnet out
Switch(config-ext-nacl)#
deny tcp 171.69.0.0 0.0.255.255 any eq telnet
Configuring ACL Logging: Examples
Two variations of logging are supported on router ACLs. The
log
keyword sends an informational logging message to the
console about the packet that matches the entry; the
log-input
keyword includes the input interface in the log entry.
In this example, standard named access list
stan1
denies traffic from 10.1.1.0 0.0.0.255, allows traffic from all other
sources, and includes the
log
keyword.
Switch(config)#
ip access-list standard stan1
Switch(config-std-nacl)#
deny 10.1.1.0 0.0.0.255 log
Switch(config-std-nacl)#
permit any log
Switch(config-std-nacl)#
exit
Switch(config)#
interface GigabitEthernet1/17
Switch(config-if)#
ip access-group stan1 in
Switch(config-if)#
end
Switch#
show logging
Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
Console logging: level debugging, 37 messages logged
Monitor logging: level debugging, 0 messages logged
Buffer logging: level debugging, 37 messages logged
File logging: disabled
Trap logging: level debugging, 39 message lines logged
Log Buffer (4096 bytes):
00:00:48: NTP: authentication delay calculation problems
<output truncated>
00:09:34:%SEC-6-IPACCESSLOGS:list stan1 permitted 0.0.0.0 1 packet
00:09:59:%SEC-6-IPACCESSLOGS:list stan1 denied 10.1.1.15 1 packet
00:10:11:%SEC-6-IPACCESSLOGS:list stan1 permitted 0.0.0.0 1 packet
This example is a named extended access list
ext1
that permits ICMP packets from any source to 10.1.1.0 0.0.0.255
and denies all UDP packets.
Switch(config)#
ip access-list extended ext1
Switch(config-ext-nacl)#
permit icmp any 10.1.1.0 0.0.0.255 log
Switch(config-ext-nacl)#
deny udp any any log
Switch(config-std-nacl)#
exit
Switch(config)#
interface GigabitEthernet1/17
Switch(config-if)#
ip access-group ext1 in
Applying a MAC ACL to a Layer 2 Interface: Examples
This example shows how to create and display an access list named
mac1
, denying only EtherType DECnet Phase IV
traffic, but permitting all other types of traffic.
Switch(config)#
mac access-list extended mac1
Switch(config-ext-macl)#
deny any any decnet-iv
Switch(config-ext-macl)#
permit any any
Switch(config-ext-macl)#
end
Содержание IE 4000
Страница 12: ...8 Configuration Overview Default Settings After Initial Switch Configuration ...
Страница 52: ...48 Configuring Interfaces Monitoring and Maintaining the Interfaces ...
Страница 108: ...104 Configuring Switch Clusters Additional References ...
Страница 128: ...124 Performing Switch Administration Additional References ...
Страница 130: ...126 Configuring PTP ...
Страница 140: ...136 Configuring CIP Additional References ...
Страница 146: ...142 Configuring SDM Templates Configuration Examples for Configuring SDM Templates ...
Страница 192: ...188 Configuring Switch Based Authentication Additional References ...
Страница 244: ...240 Configuring IEEE 802 1x Port Based Authentication Additional References ...
Страница 274: ...270 Configuring SGT Exchange Protocol over TCP SXP and Layer 3 Transport Configuring Cisco TrustSec Caching ...
Страница 298: ...294 Configuring VLANs Additional References ...
Страница 336: ...332 Configuring STP Additional References ...
Страница 408: ...404 Configuring DHCP Additional References ...
Страница 450: ...446 Configuring IGMP Snooping and MVR Additional References ...
Страница 490: ...486 Configuring SPAN and RSPAN Additional References ...
Страница 502: ...498 Configuring Layer 2 NAT ...
Страница 559: ...555 Configuring Network Security with ACLs How to Configure Network Security with ACLs Creating a Numbered Extended ACL ...
Страница 770: ...766 Configuring IPv6 MLD Snooping Related Documents ...
Страница 930: ...926 Configuring IP Unicast Routing Related Documents ...
Страница 956: ...952 Configuring IPv6 Unicast Routing Configuring IPv6 network 2010 AB8 2 48 network 2010 AB8 3 48 exit address family ...
Страница 976: ...972 Configuring Cisco IOS IP SLAs Operations Additional References ...
Страница 978: ...974 Dying Gasp ...
Страница 990: ...986 Configuring Enhanced Object Tracking Monitoring Enhanced Object Tracking ...
Страница 994: ...990 Configuring MODBUS TCP Displaying MODBUS TCP Information ...
Страница 996: ...992 Ethernet CFM ...
Страница 1030: ...1026 Working with the Cisco IOS File System Configuration Files and Software Images Working with Software Images ...
Страница 1066: ...1062 Using an SD Card SD Card Alarms ...