34-32
Cisco ME 3800X and 3600X Switch Software Configuration Guide
OL-23400-01
Chapter 34 Configuring MPLS, MPLS VPN, MPLS OAM, and EoMPLS
Enabling EoMPLS
Beginning in privileged EXEC mode, follow these steps on the provider-edge routers to configure
EoMPLS to transport Layer 2 packets between two endpoints:
Use the no xconnect
destination vc-id
encapsulation mpls
interface command to delete the EoMPLS
tunnel.
This example shows how to configure an EoMPLS tunnel between switch PE1’s routed port and PE2’s
VLAN 4 interface.
PE1 has an IP address 10.0.0.1/32, and PE2 has IP address 20.0.01/32. Both provider-edge routers are
configured with an MPLS connection to the MPLS core. The VC ID is 123.
Enter these commands on the PE1 switch:
Switch(config)#
interface loopback0
Switch(config-if)#
ip address 10.10.10.10 255.255.255.255
Switch(config-if)#
exit
Switch(config)#
interface GigabitEthernet0/1
Switch(config-if)#
xconnect 20.20.20.20 123 encapsulation mpls
Enter these commands on the PE2 switch:
Switch(config)#
interface loopback0
Switch(config-if)#
ip address 20.20.20.20 255.255.255.255
Switch(config-if)#
exit
Switch(config)#
interface vlan 4
Switch(config-if)#
xconnect 10.10.10.10 123 encapsulation mpls
Command
Purpose
Step 1
configure terminal
Enter global configuration mode.
Step 2
mpls label protocol ldp
Enable LDP for all interfaces. By default, TDP is enabled. This command
causes all interfaces to use LDP.
Step 3
interface loopback0
Enter interface configuration mode for a loopback interface.
Step 4
ip address ip-address subnet mask
Assign an IP address to the loopback interface.
Step 5
exit
Return to global configuration mode.
Step 6
interface vlan vlan-id
or
interface interface-id
Enter a VLAN ID (for VLAN-based EoMPLS) to enter SVI configuration
mode.
or
Enter the interface ID of a routed port (for port-based EoMPLS), to enter
routed port interface configuration mode.
Step 7
xconnect destination vc-id
encapsulation mpls
Configure the interface to transport the Layer 2 VLAN packets over MPLS.
•
destination—IP address of the provider-edge router at the other end of
the virtual connection.
•
vc-id—Unique value defined for the virtual connection. The VC-ID
connects the end points of the virtual connection and must be the same
on both ends of the connection. The range is from 1 to 4294967295.
Note
Use the xconnect command if pseudowire redundancy is required.
Step 8
end
Return to privileged EXEC mode.
Step 9
show mpls l2transport vc
Verify the configuration.
Step 10
copy running-config startup-config (Optional) Save your entries in the configuration file.