29-91
Cisco ME 3800X and 3600X Switch Software Configuration Guide
OL-23400-01
Chapter 29 Configuring IP Unicast Routing
Configuring Multi-VRF CE
Switch(config-router-af)#
neighbor 38.0.0.3 remote-as 100
Switch(config-router-af)#
neighbor 38.0.0.3 activate
Switch(config-router-af)#
network 8.8.1.0 mask 255.255.255.0
Switch(config-router-af)#
end
Configuring Switch D
Switch D belongs to VPN 1. Configure the connection to Switch A by using these commands.
Switch#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
ip routing
Switch(config)#
interface fastethernet0/2
Switch(config-if)#
no shutdown
Switch(config-if)#
no switchport
Switch(config-if)#
ip address 208.0.0.20 255.255.255.0
Switch(config-if)#
exit
Switch(config)#
router ospf 101
Switch(config-router)#
network 208.0.0.0 0.0.0.255 area 0
Switch(config-router)#
end
Configuring Switch F
Switch F belongs to VPN 2. Configure the connection to Switch A by using these commands.
Switch#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
ip routing
Switch(config)#
interface fastethernet0/1
Switch(config-if)#
no shutdown
Switch(config-if)#
switchport trunk encapsulation dot1q
Switch(config-if)#
switchport mode trunk
Switch(config-if)#
no ip address
Switch(config-if)#
exit
Switch(config)#
interface vlan118
Switch(config-if)#
ip address 118.0.0.11 255.255.255.0
Switch(config-if)#
exit
Switch(config)#
router ospf 101
Switch(config-router)#
network 118.0.0.0 0.0.0.255 area 0
Switch(config-router)#
end
Configuring the PE Switch B
On Switch B (the PE router), these commands configure only the connections to the CE device,
Switch A.
Router#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
ip vrf v1
Router(config-vrf)#
rd 100:1
Router(config-vrf)#
route-target export 100:1
Router(config-vrf)#
route-target import 100:1
Router(config-vrf)#
exit
Router(config)#
ip vrf v2
Router(config-vrf)#
rd 100:2
Router(config-vrf)#
route-target export 100:2
Router(config-vrf)#
route-target import 100:2
Router(config-vrf)#
exit