2-499
Cisco Catalyst Blade Switch 3030 Command Reference
78-17262-01
Chapter 2 Cisco
Catalyst
Blade Switch 3030 Cisco IOS Commands
switchport mode
To autonegotiate trunking, the interfaces must be in the same VLAN Trunking Protocol (VTP) domain.
Trunk negotiation is managed by the Dynamic Trunking Protocol (DTP), which is a point-to-point
protocol. However, some internetworking devices might forward DTP frames improperly, which could
cause misconfigurations. To avoid this, you should configure interfaces connected to devices that do not
support DTP to not forward DTP frames, which turns off DTP.
•
If you do not intend to trunk across those links, use the
switchport mode access
interface
configuration command to disable trunking.
•
To enable trunking to a device that does not support DTP, use the
switchport mode trunk
and
switchport nonegotiate
interface configuration commands to cause the interface to become a trunk
but to not generate DTP frames.
Access ports trunk ports are mutually exclusive.
The IEEE 802.1x feature interacts with switchport modes in these ways:
•
If you try to enable IEEE 802.1x on a trunk port, an error message appears, and IEEE 802.1x is not
enabled. If you try to change the mode of an IEEE 802.1x-enabled port to trunk, the port mode is
not changed.
•
If you try to enable IEEE 802.1x on a port set to
dynamic auto
or
dynamic desirable
, an error
message appears, and IEEE 802.1x is not enabled. If you try to change the mode of an
IEEE 802.1x-enabled port to
dynamic auto
or
dynamic desirable
, the port mode is not changed.
•
If you try to enable IEEE 802.1x on a dynamic-access (VLAN Query Protocol [VQP]) port, an error
message appears, and IEEE 802.1x is not enabled. If you try to change an IEEE 802.1x-enabled port
to dynamic VLAN assignment, an error message appears, and the VLAN configuration is not
changed.
Examples
This example shows how to configure a port for access mode:
Switch(config)#
interface gigabitethernet0/1
Switch(config-if)#
switchport mode access
This example shows how set the port to dynamic desirable mode:
Switch(config)#
interface gigabitethernet0/1
Switch(config-if)#
switchport mode dynamic desirable
This example shows how to configure a port for trunk mode:
Switch(config)#
interface gigabitethernet0/1
Switch(config-if)#
switchport mode trunk
You can verify your settings by entering the
show interfaces
interface-id
switchport
privileged EXEC
command and examining information in the Administrative Mode and Operational Mode rows.
Related Commands
Command
Description
show interfaces
switchport
Displays the administrative and operational status of a switching
port, including port blocking and port protection settings.
switchport access
Configures a port as a static-access or dynamic-access port.
switchport trunk
Configures the trunk characteristics when an interface is in trunking
mode.