! Configure VPLS instance vplsA.
host1(config)#
bridge vplsA vpls transport-virtual-router default
!
! Configure VPLS instance vplsB.
host1(config)#
bridge vplsB vpls transport-virtual-router default
!
! Configure Fast Ethernet interface 2/1 between PE 1 and CE 1,
! and assign it to vplsA as a trunk interface.
host1(config)#
interface fastEthernet 2/1
host1(config-if)#
bridge-group vplsA subscriber-trunk
host1(config-if)#
exit
!
! Configure bridged Ethernet interface 6/0.12 between PE 1 and CE 2,
! and assign it to vplsB as a trunk interface.
host1(config)#
interface atm 6/0.12 point-to-point
host1(config-subif)#
atm pvc 12 0 12 aal5snap 0 0 0
host1(config-subif)#
encapsulation bridge1483 mac-address 0090.1a40.9991
host1(config-subif)#
bridge-group vplsB subscriber-trunk
host1(config-if)#
exit
!
! Configure LDP signaling for vplsA.
host1(config)#
mpls ldp vpls vplsA vpls-id 1
host1(config)#
mpls ldp vpls vplsA neighbor 2.2.2.2
! Configure LDP signaling for vplsB.
host1(config)#
mpls ldp vpls vplsB vpls-id 2
host1(config)#
mpls ldp vpls vplsB neighbor 2.2.2.2
!
! Configure a loopback interface on PE 1 and assign it an IP address.
host1(config)#
interface loopback 0
host1(config-if)#
ip address 1.1.1.1 255.255.255.255
host1(config-if)#
exit
!
! Assign the router ID for PE 1 using the IP address of the loopback interface.
host1(config)#
ip router-id 1.1.1.1
!
! Configure ATM core-facing interface 6/0.10 between PE 1 and the P router,
! and assign it an IP address.
host1(config)#
interface atm 6/0.10 point-to-point
host1(config-subif)#
atm pvc 10 0 10 aal5snap 0 0 0
host1(config-subif)#
ip address 10.10.10.1 255.255.255.0
!
! Enable MPLS, LDP, and topology-driven LSPs on the core-facing interface.
host1(config-subif)#
mpls
host1(config-subif)#
mpls ldp
host1(config-subif)#
exit
!
! Configure OSPF routing in the core MPLS network.
host1(config)#
router ospf 1
host1(config-router)#
network 1.1.1.1 0.0.0.0 area 0.0.0.0
host1(config-router)#
network 10.10.10.0 0.0.0.255 area 0.0.0.0
host1(config-router)#
exit
Configuration on PE 2 (Remote PE Router)
Use the following commands on the remote PE router (PE 2) to configure the VPLS
topology shown in Figure 130 on page 606.
607
Copyright © 2010, Juniper Networks, Inc.
Chapter 12: Configuring VPLS
Содержание JUNOSE 11.2.X BGP AND MPLS
Страница 6: ...Copyright 2010 Juniper Networks Inc vi...
Страница 8: ...Copyright 2010 Juniper Networks Inc viii JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 38: ...Copyright 2010 Juniper Networks Inc 2 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 192: ...Copyright 2010 Juniper Networks Inc 156 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 242: ...Copyright 2010 Juniper Networks Inc 206 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 244: ...Copyright 2010 Juniper Networks Inc 208 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 310: ...Copyright 2010 Juniper Networks Inc 274 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 356: ...Copyright 2010 Juniper Networks Inc 320 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 418: ...Copyright 2010 Juniper Networks Inc 382 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 524: ...Copyright 2010 Juniper Networks Inc 488 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 544: ...Copyright 2010 Juniper Networks Inc 508 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 608: ...Copyright 2010 Juniper Networks Inc 572 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 672: ...Copyright 2010 Juniper Networks Inc 636 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 674: ...Copyright 2010 Juniper Networks Inc 638 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 716: ...Copyright 2010 Juniper Networks Inc 680 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 717: ...PART 6 Index Index on page 683 681 Copyright 2010 Juniper Networks Inc...
Страница 718: ...Copyright 2010 Juniper Networks Inc 682 JunosE 11 2 x BGP and MPLS Configuration Guide...