! Configure BGP signaling.
host1(config)#
router bgp 100
host1(config-router)#
neighbor 10.2.2.2 remote-as 100
host1(config-router)#
neighbor 10.2.2.2 update-source loopback 0
host1(config-router)#
neighbor 10.2.2.2 next-hop-self
host1(config-router)#
address-family l2vpn signaling
host1(config-router-af)#
neighbor 10.2.2.2 activate
host1(config-router-af)#
neighbor 10.2.2.2 next-hop-self
host1(config-router-af)#
exit-address-family
host1(config-router)#
address-family vpls vplsA
host1(config-router-af)#
exit-address-family
host1(config-router)#
address-family vpls vplsB
host1(config-router-af)#
exit-address-family
host1(config-router)#
exit
Configuration on PE 2 (Remote PE Router)
Use the following commands on the remote PE router (PE 2) to configure the VPLS
topology shown in Figure 129 on page 599.
! Configure VPLS instance vplsA. The route target (100:1)
! matches the route target configured for vplsA on PE 1.
host2(config)#
bridge vplsA vpls transport-virtual-router default
host2(config)#
bridge vplsA vpls site-range 10
host2(config)#
bridge vplsA vpls site-name chicago site-id 2
host2(config)#
bridge vplsA vpls rd 100:21
host2(config)#
bridge vplsA vpls route-target both 100:1
!
! Configure VPLS instance vplsB. The route target (100:2)
! matches the route target configured for vplsB on PE 1.
host2(config)#
bridge vplsB vpls transport-virtual-router default
host2(config)#
bridge vplsB vpls site-range 20
host2(config)#
bridge vplsB vpls site-name chicago site-id 2
host2(config)#
bridge vplsB vpls rd 100:22
host2 (config)#
bridge vplsB vpls route-target both 100:2
! Configure Fast Ethernet interface 3/5 between PE 2 and CE 3,
! and assign it to vplsA as a trunk interface.
host2(config)#
interface fastEthernet 3/5
host2(config-if)#
bridge-group vplsA subscriber-trunk
host2(config-if)#
exit
!
! Configure bridged Ethernet interface 2/0.21 between PE 2 and CE 4,
! and assign it to vplsB as a trunk interface.
host2(config)#
interface atm 2/0.21 point-to-point
host2(config-subif)#
atm pvc 21 0 21 aal5snap 0 0 0
host2(config-subif)#
encapsulation bridge1483 mac-address 0090.1a40.9992
host2(config-subif)#
bridge-group vplsB subscriber-trunk
host2(config-if)#
exit
!
! Configure a loopback interface on PE 2 and assign it an IP address.
host2(config)#
interface loopback 0
host2(config-if)#
ip address 10.2.2.2 255.255.255.255
host2(config-if)#
exit
!
! Assign the router ID for PE 2 using the IP address of the loopback interface.
host2(config)#
ip router-id 10.2.2.2
601
Copyright © 2010, Juniper Networks, Inc.
Chapter 12: Configuring VPLS
Содержание JUNOSE 11.2.X BGP AND MPLS
Страница 6: ...Copyright 2010 Juniper Networks Inc vi...
Страница 8: ...Copyright 2010 Juniper Networks Inc viii JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 38: ...Copyright 2010 Juniper Networks Inc 2 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 192: ...Copyright 2010 Juniper Networks Inc 156 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 242: ...Copyright 2010 Juniper Networks Inc 206 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 244: ...Copyright 2010 Juniper Networks Inc 208 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 310: ...Copyright 2010 Juniper Networks Inc 274 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 356: ...Copyright 2010 Juniper Networks Inc 320 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 418: ...Copyright 2010 Juniper Networks Inc 382 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 524: ...Copyright 2010 Juniper Networks Inc 488 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 544: ...Copyright 2010 Juniper Networks Inc 508 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 608: ...Copyright 2010 Juniper Networks Inc 572 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 672: ...Copyright 2010 Juniper Networks Inc 636 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 674: ...Copyright 2010 Juniper Networks Inc 638 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 716: ...Copyright 2010 Juniper Networks Inc 680 JunosE 11 2 x BGP and MPLS Configuration Guide...
Страница 717: ...PART 6 Index Index on page 683 681 Copyright 2010 Juniper Networks Inc...
Страница 718: ...Copyright 2010 Juniper Networks Inc 682 JunosE 11 2 x BGP and MPLS Configuration Guide...