[Router-vlan10]
quit
# Add Ethernet0/0/0 to VLAN 10.
[Router]
interface ethernet 0/0/0
[Router-Ethernet0/0/0]
port hybrid tagged vlan 10
# Configure an IP address for VLANIF 10.
[Router]
interface vlanif 10
[Router-Vlanif10]
ip address 100.1.1.12 255.255.255.0
[Router-Vlanif10]
quit
Step 2
Configure the Router.
Create VLAN 10 on the Router and add all interfaces to VLAN 10. Configure isolation for
downstream interfaces connected to users. The configuration details are not mentioned here.
Step 3
Configure IP addresses for PCs.
# Configure IP addresses for PCs and ensure that their IP addresses and the IP address of
VLANIF10 are on the same network segment.
# After the configuration is complete, each PC and the Router can be pinged successfully. PCs,
however, cannot be pinged.
Step 4
Enable intra-VLAN proxy ARP on VLANIF 10.
[Router]
interface vlanif 10
[Router-Vlanif10]
arp-proxy inner-sub-vlan-proxy enable
[Router-Vlanif10]
quit
Step 5
Verify the configuration.
# Ping PC A and PC B. They can be pinged successfully.
[Router]
ping 100.1.1.100
PING 100.1.1.100: 56 data bytes, press CTRL_C to break
Reply from 100.1.1.100: bytes=56 Sequence=1 ttl=255 time=10 ms
Reply from 100.1.1.100: bytes=56 Sequence=2 ttl=255 time=10 ms
Reply from 100.1.1.100: bytes=56 Sequence=3 ttl=255 time=10 ms
Reply from 100.1.1.100: bytes=56 Sequence=4 ttl=255 time=10 ms
Reply from 100.1.1.100: bytes=56 Sequence=5 ttl=255 time=10 ms
--- 100.1.1.100 ping statistics ---
5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 10/10/10 ms
----End
Configuration Files
Configuration file of the Router
#
sysname Router
#
vlan batch 10
#
interface Vlanif 10
ip address 100.1.1.12 255.255.255.0
arp-proxy inner-sub-vlan-proxy enable
#
interface ethernet 0/0/0
port hybrid tagged vlan 10
Huawei AR150&200 Series Enterprise Routers
Configuration Guide - IP Service
1 ARP Configuration
Issue 02 (2012-03-30)
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
31