Procedure
Step 1
Configure static ARP entries for the host in the headquarters office on the Router.
# Create VLAN 10.
<Huawei>
system-view
[Huawei]
sysname Router
[Router]
vlan 10
[Router-vlan10]
quit
# Add Ethernet0/0/0 to VLAN 10.
[Router]
interface ethernet 0/0/0
[Router-Ethernet0/0/0]
port hybrid tagged vlan 10
# Configure an IP address for VLANIF 10.
[Router]
interface vlanif 10
[Router-Vlanif10]
ip address 10.164.1.20 255.255.255.0
[Router-Vlanif10]
quit
# Configure static ARP entries for hosts in the headquarters office. Configuring a static ARP
entry for PC A is used as an example. In the static ARP entry, PCA IP address 10.164.1.1 maps
the MAC address 00e0-fc01-0001, and the VLAN ID is 10 and the outbound interface is
Ethernet0/0/0.
[Router]
arp static 10.164.1.1 00e0-fc01-0001 vid 10 interface ethernet 0/0/0
# Configure static ARP entries for other hosts in the headquarters office. The configuration
method is similar to that of PC A.
Step 2
Configure a static ARP entry for the file backup server on the Router.
# Configure an IP address for Ethernet2/0/0.
[Router]
interface ethernet 2/0/0
[Router-Ethernet2/0/0]
ip address 10.164.10.10 255.255.255.0
[Router-Ethernet2/0/0]
quit
# Configure a static ARP entry for the file backup server: The IP address 10.164.10.1/24 maps
the MAC address 0df0-fc01-003a.
[Router]
arp static 10.164.10.1 0df0-fc01-003a
Step 3
Verify the configuration.
# Run the
display current-configuration
command to view static ARP entries.
<Router>
display current-configuration | include arp
arp static 10.164.1.1 00e0-fc01-0001 vid 10 interface ethernet 0/0/0
arp static 10.164.1.2 00e0-fc01-0002 vid 10 interface ethernet 0/0/0
arp static 10.164.1.3 00e0-fc01-0003 vid 10 interface ethernet 0/0/0
arp static 10.164.10.1 0df0-fc01-003a
----End
Example
The following lists the configuration file of the Router.
#
sysname Router
#
vlan batch 10 20 30
Huawei AR150&200 Series Enterprise Routers
Configuration Guide - IP Service
1 ARP Configuration
Issue 02 (2012-03-30)
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
26