Procedure
Step 1
Configure IP addresses for the interfaces on the AR150/200 and configure the NAT server on
the WAN-side interface.
<Huawei>
system-view
[Huawei]
vlan 100
[Huawei-vlan100]
quit
[Huawei]
interface vlanif 100
[Huawei-Vlanif100]
ip address 192.168.20.1 24
[Huawei-Vlanif100]
quit
[Huawei]
interface Ethernet 0/0/0
[Huawei-Ethernet0/0/0]
port link-type access
[Huawei-Ethernet0/0/0]
port default vlan 100
[Huawei-Ethernet0/0/0]
quit
[Huawei]
vlan 200
[Huawei-vlan200]
quit
[Huawei]
interface vlanif 200
[Huawei-Vlanif200]
ip address 10.0.0.1 24
[Huawei-Vlanif200]
quit
[Huawei]
interface Ethernet 0/0/1
[Huawei-Ethernet0/0/1]
port link-type access
[Huawei-Ethernet0/0/1]
port default vlan 200
[Huawei-Ethernet0/0/1]
quit
[Huawei]
interface ethernet 2/0/0
[Huawei-Ethernet2/0/0]
ip address 202.169.10.1 24
[Huawei-Ethernet2/0/0]
nat server protocol tcp global 202.169.10.5 www inside
192.168.20.2 8080
[Huawei-Ethernet2/0/0]
nat server protocol tcp global 202.169.10.33 ftp inside
10.0.0.3 ftp
[Huawei-Ethernet2/0/0]
quit
Step 2
On the AR150/200, configure a static route with the next hop address 202.169.10.2
[Huawei]
ip route-static 0.0.0.0 0.0.0.0 202.169.10.2
Step 3
Enable the NAT ALG function for FTP packets on the AR150/200.
[Huawei]
nat alg ftp enable
Step 4
Verify the configuration.
Run the
display nat server
command on the AR150/200 to view the NAT server configuration.
[Huawei]
display nat server
Nat Server Information:
Interface : Ethernet2/0/0
Global IP/Port : 202.169.10.5/80(www)
Inside IP/Port : 192.168.20.2/8080
Protocol : 6(tcp)
VPN instance-name : ----
Acl number : ----
Global IP/Port : 202.169.10.33/21(ftp)
Inside IP/Port : 10.0.0.3/21(ftp)
Protocol : 6(tcp)
VPN instance-name : ----
Acl number : ----
Total : 2
Run the
display nat alg
command on the AR150/200, and the command output is as follows:
[Huawei]
display nat alg
NAT Application Level Gateway Information:
----------------------------------
Application Status
----------------------------------
dns Disabled
Huawei AR150&200 Series Enterprise Routers
Configuration Guide - IP Service
5 NAT Configuration
Issue 02 (2012-03-30)
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
118