276
[P-Vlan-interface15] ip address 192.168.7.2 24
[P-Vlan-interface15] pim sm
[P-Vlan-interface15] mpls
[P-Vlan-interface15] mpls ldp
[P-Vlan-interface15] quit
# Configure an IP address, and enable PIM-SM and LDP capability on the public network
interface VLAN-interface 19.
[P] interface vlan-interface 19
[P-Vlan-interface19] ip address 192.168.8.2 24
[P-Vlan-interface19] pim sm
[P-Vlan-interface19] mpls
[P-Vlan-interface19] mpls ldp
[P-Vlan-interface19] quit
# Configure an IP address for Loopback 1, and enable PIM-SM.
[P] interface loopback 1
[P-LoopBack1] ip address 2.2.2.2 32
[P-LoopBack1] pim sm
[P-LoopBack1] quit
# Configure Loopback 1 as a C-BSR and a C-RP for the public network instance.
[P] pim
[P-pim] c-bsr loopback 1
[P-pim] c-rp loopback 1
[P-pim] quit
# Configure OSPF.
[P] ospf 1
[P-ospf-1] area 0.0.0.0
[P-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
[P-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.255.255
5.
Configure CE a1:
# Enable IP multicast routing.
<CEa1> system-view
[CEa1] multicast routing-enable
# Configure an IP address for VLAN-interface 10 and enable PIM-SM on the interface.
[CEa1] interface vlan-interface 10
[CEa1-Vlan-interface10] ip address 10.110.7.1 24
[CEa1-Vlan-interface10] pim sm
[CEa1-Vlan-interface10] quit
# Configure an IP address for VLAN-interface 11 and enable PIM-SM on the interface.
[CEa1] interface vlan-interface 11
[CEa1-Vlan-interface11] ip address 10.110.2.2 24
[CEa1-Vlan-interface11] pim sm
[CEa1-Vlan-interface11] quit
# Configure RIP
[CEa1] rip 2
[CEa1-rip-2] network 10.0.0.0
6.
Configure CE b1:
# Enable IP multicast routing.