[MCE]
interface xgigabitethernet 0/0/1
[MCE-XGigabitEthernet0/0/1]
port link-type trunk
[MCE-XGigabitEthernet0/0/1]
port trunk allow-pass vlan 30 40
[MCE-XGigabitEthernet0/0/1]
quit
[MCE]
interface xgigabitethernet 0/0/3
[MCE-XGigabitEthernet0/0/3]
port link-type trunk
[MCE-XGigabitEthernet0/0/3]
port trunk allow-pass vlan 10
[MCE-XGigabitEthernet0/0/3]
quit
[MCE]
interface xgigabitethernet 0/0/4
[MCE-XGigabitEthernet0/0/4]
port link-type trunk
[MCE-XGigabitEthernet0/0/4]
port trunk allow-pass vlan 20
[MCE-XGigabitEthernet0/0/4]
quit
# Create sub-interfaces on PE2 and add these sub-interfaces to the VLAN.
<Quidway>
system-view
[Quidway]
sysname PE2
[PE2]
interface gigabitethernet 1/0/1.1
[PE2-GigabitEthernet1/0/1.1]
vlan-type dot1q 30
[PE2-GigabitEthernet1/0/1.1]
quit
[PE2]
interface gigabitethernet 1/0/1.2
[PE2-GigabitEthernet1/0/1.2]
vlan-type dot1q 40
[PE2-GigabitEthernet1/0/1.2]
quit
# Create a VLAN on CE3.
<Quidway>
system-view
[Quidway]
sysname CE3
[CE3]
vlan 10
# Add an interface to the VLAN on CE3.
[CE3-A]
interface xgigabitethernet 0/0/1
[CE3-XGigabitEthernet0/0/1]
port link-type trunk
[CE3-XGigabitEthernet0/0/1]
port trunk allow-pass vlan 10
[CE3-XGigabitEthernet0/0/1]
quit
# Create a VLAN on CE4.
The configuration on CE4 is similar to that on CE3, and is not mentioned here.
# Add an interface to the VLAN on CE4.
The configuration on CE4 is similar to that on CE3, and is not mentioned here.
2.
Create and configure VPN instances.
# Create VPN instances on the MCE.
[MCE]
ip vpn-instance vpna
[MCE-vpn-instance-vpna]
route-distinguisher 100:1
[MCE-vpn-instance-vpna]
quit
[MCE]
ip vpn-instance vpnb
[MCE-vpn-instance-vpnb]
route-distinguisher 100:2
[MCE-vpn-instance-vpnb]
quit
# Bind VPN instances to VLANIF interfaces on the MCE and assign IP addresses to the
VLANIF interfaces.
[MCE]
interface vlanif 10
[MCE-Vlanif10]
ip binding vpn-instance vpnb
[MCE-Vlanif10]
ip address 192.168.1.1 24
[MCE-Vlanif10]
quit
[MCE]
interface vlanif 20
[MCE-Vlanif20]
ip binding vpn-instance vpna
[MCE-Vlanif20]
ip address 192.168.2.1 24
[MCE-Vlanif20]
quit
[MCE]
interface vlanif 30
[MCE-Vlanif30]
ip binding vpn-instance vpnb
[MCE-Vlanif30]
ip address 172.18.1.2 16
[MCE-Vlanif30]
quit
[MCE]
interface vlanif 40
[MCE-Vlanif40]
ip binding vpn-instance vpna
[MCE-Vlanif40]
ip address 172.19.1.2 16
[MCE-Vlanif40]
quit
S6700 Series Ethernet Switches
Configuration Guide - IP Routing
11 MCE Configuration
Issue 01 (2012-03-15)
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
642