21-9
Cisco 7600 Series Router Cisco IOS Software Configuration Guide, Release 12.2SX
OL-4266-08
Chapter 21 Configuring Optional STP Features
Enabling PortFast
This example shows how to enable PortFast on Fast Ethernet interface 5/8:
Router#
configure terminal
Router(config)#
interface fastethernet 5/8
Router(config-if)#
spanning-tree portfast
Router(config-if)#
end
Router#
This example shows how to verify the configuration:
Router#
show running-config interface fastethernet 5/8
Building configuration...
Current configuration:
!
interface FastEthernet5/8
no ip address
switchport
switchport access vlan 200
switchport mode access
spanning-tree portfast
end
Router#
To enable the default PortFast configuration, perform this task:
This example shows how to enable the default PortFast configuration:
Router#
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
spanning-tree portfast default
Router(config)#
^Z
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is disabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
Step 4
Router(config-if)#
end
Exits configuration mode.
Step 5
Router#
show running interface
{
type
1
slot/port
} |
{
port-channel
port_channel_number
}
Verifies the configuration.
1.
type
=
ethernet
,
fastethernet
,
gigabitethernet
, or
tengigabitethernet
Command
Purpose
Command
Purpose
Step 1
Router(config)#
spanning-tree portfast default
Configures the PortFast default.
Step 2
Router(config)#
show spanning-tree summary totals
Verifies the global configuration.
Step 3
Router(config)#
show spanning-tree interface
x
detail
Verifies the effect on a specific port.
Step 4
Router(config-if)#
spanning-tree portfast trunk
Enables the PortFast trunk on a port
Step 5
Router#
show spanning-tree interface fastEthernet
x
detail
Verifies the configuration.