Purpose
Command or Action
Sets the port channel to support an external
Fabric Extender.
switchport mode fex-fabric
Example:
switch(config-if)# switchport mode
fex-fabric
Step 3
Associates a FEX number to the Fabric
Extender unit attached to the interface. The
range is from 100 to 199.
fex associate FEX-number
Example:
switch(config-if)# fex associate 101
Step 4
(Optional)
Displays the association of a Fabric Extender
to a port channel interface.
show interface port-channel channel fex-intf
Example:
switch# show interface port-channel 4
fex-intf
Step 5
This example shows how to associate the Fabric Extender to a port channel interface on the parent device:
switch#
configure terminal
switch(config)#
interface ethernet 1/28
switch(config-if)#
channel-group 4
switch(config-if)#
no shutdown
switch(config-if)#
exit
switch(config)#
interface ethernet 1/29
switch(config-if)#
channel-group 4
switch(config-if)#
no shutdown
switch(config-if)#
exit
switch(config)#
interface ethernet 1/30
switch(config-if)#
channel-group 4
switch(config-if)#
no shutdown
switch(config-if)#
exit
switch(config)#
interface ethernet 1/31
switch(config-if)#
channel-group 4
switch(config-if)#
no shutdown
switch(config-if)#
exit
switch(config)#
interface port-channel 4
switch(config-if)#
switchport
switch(config-if)#
switchport mode fex-fabric
switch(config-if)#
fex associate 101
As a best practice, only enter the
fex associate
command from the port channel interface, not from the
physical interface.
Tip
When adding physical interfaces to port channels, all configurations on the port channel and physical
interface must match.
Note
This example shows how to display the association of the Fabric Extender and the parent device:
switch#
show interface port-channel 4 fex-intf
Fabric
FEX
Interface
Interfaces
---------------------------------------------------
Po4
Eth101/1/48
Eth101/1/47
Eth101/1/46
Eth101/1/45
Eth101/1/44
Eth101/1/43
Eth101/1/42
Eth101/1/41
Cisco Nexus 6000 Series NX-OS Layer 2 Switching Configuration Guide, Release 7.x
167
Configuring the Fabric Extender
Associating a Fabric Extender to a Port Channel