10: Configuring an Ethernet interface
_______________________________________________________________________________________________________
_______________________________________________________________________________________________________
© Virtual Access 2018
GW6600 Series User manual
Issue: 1.7
Page 101 of 519
dhcp.@dhcp[0]=dhcp
dhcp.@dhcp[0].interface=newinterface
dhcp.@dhcp[0].mode=ipv4
dhcp.@dhcp[0].start=100
dhcp.@dhcp[0].limit=150
dhcp.@dhcp[0].leasetime=12h
To change any of the above values use
uci set
command.
10.3.2
Interface configuration using package options
root@VA_router:~# uci export network
package network
……
config interface 'newinterface'
option proto 'static'
option ifname 'eth0'
option monitored '0'
option ipaddr '2.2.2.2'
option netmask '255.255.255.0'
option gateway '2.2.2.10'
option broadcast '2.2.2.255'
list vlan_qos_map_ingress '1:2'
list vlan_qos_map_ingress '2:1'
config alias 'ethalias1'
option proto 'static'
option interface 'newinterface'
option ipaddr '10.10.10.1'
option netmask '255.255.255.0'
option gateway '10.10.10.10'
option bcast '10.10.10.255'
option dns '8.8.8.8'
root@VA_router:~# uci export firewall
package firewall
config zone
option name 'lan'