Device(dhcp-config)#
boot config-boot.text
Device(dhcp-config)#
default-router 10.10.10.1
Device(dhcp-config)#
option 150 10.10.10.1
Device(dhcp-config)#
exit
Device(config)#
tftp-server flash:config-boot.text
Device(config)#
interface gigabitethernet1/0/4
Device(config-if)#
no switchport
Device(config-if)#
ip address 10.10.10.1 255.255.255.0
Device(config-if)#
end
Example: Configuring DHCP Auto-Image Update
Device#
configure terminal
Device(config)#
ip dhcp pool pool1
Device(dhcp-config)#
network 10.10.10.0 255.255.255.0
Device(dhcp-config)#
boot config-boot.text
Device(dhcp-config)#
default-router 10.10.10.1
Device(dhcp-config)#
option 150 10.10.10.1
Device(dhcp-config)#
option 125 hex 0000.0009.0a05.08661.7574.6f69.6e73.7461.6c6c.5f64.686370
Device(dhcp-config)#
exit
Device(config)#
tftp-server flash:config-boot.text
Device(config)#
tftp-server flash:image_name
Device(config)#
tftp-server flash:boot-config.text
Device(config)#
tftp-server flash: autoinstall_dhcp
Device(config)#
interface gigabitethernet1/0/4
Device(config-if)#
no switchport
Device(config-if)#
ip address 10.10.10.1 255.255.255.0
Device(config-if)#
end
Example: Configuring a Device to Download Configurations from a DHCP
Server
This example uses a Layer 3 SVI interface on VLAN 99 to enable DHCP-based autoconfiguration with a
saved configuration:
Device#
configure terminal
Device(config)#
boot host dhcp
Device(config)#
boot host retry timeout 300
Device(config)#
banner config-save ^C Caution - Saving Configuration File to NVRAM May Cause
You to No longer Automatically Download Configuration Files at Reboot^C
Device(config)#
vlan 99
Device(config-vlan)#
interface vlan 99
Device(config-if)#
no shutdown
Device(config-if)#
end
Device#
show boot
BOOT path-list:
Config file:
flash:/config.text
Private Config file:
flash:/private-config.text
Enable Break:
no
Manual Boot:
no
HELPER path-list:
NVRAM/Config file
buffer size:
32768
Timeout for Config
System Management Configuration Guide, Cisco IOS XE Gibraltar 16.10.x (Catalyst 9200 Switches)
82
Performing Device Setup Configuration
Example: Configuring DHCP Auto-Image Update