host1(config)#
bridge vplsA vpls transport-virtual-router default
!
! Configure VPLS instance vplsB.
host1(config)#
bridge vplsB vpls transport-virtual-router default
!
! Configure Fast Ethernet interface 2/1 between PE 1 and CE 1,
! and assign it to vplsA as a trunk interface.
host1(config)#
interface fastEthernet 2/1
host1(config-if)#
bridge-group vplsA subscriber-trunk
host1(config-if)#
exit
!
! Configure bridged Ethernet interface 6/0.12 between PE 1 and CE 2,
! and assign it to vplsB as a trunk interface.
host1(config)#
interface atm 6/0.12 point-to-point
host1(config-subif)#
atm pvc 12 0 12 aal5snap 0 0 0
host1(config-subif)#
encapsulation bridge1483 mac-address 0090.1a40.9991
host1(config-subif)#
bridge-group vplsB subscriber-trunk
host1(config-if)#
exit
!
! Configure LDP signaling for vplsA.
host1(config)#
mpls ldp vpls vplsA vpls-id 1
host1(config)#
mpls ldp vpls vplsA neighbor 2.2.2.2
! Configure LDP signaling for vplsB.
host1(config)#
mpls ldp vpls vplsB vpls-id 2
host1(config)#
mpls ldp vpls vplsB neighbor 2.2.2.2
!
! Configure a loopback interface on PE 1 and assign it an IP address.
host1(config)#
interface loopback 0
host1(config-if)#
ip address 1.1.1.1 255.255.255.255
host1(config-if)#
exit
!
! Assign the router ID for PE 1 using the IP address of the loopback interface.
host1(config)#
ip router-id 1.1.1.1
!
! Configure ATM core-facing interface 6/0.10 between PE 1 and the P router,
! and assign it an IP address.
host1(config)#
interface atm 6/0.10 point-to-point
host1(config-subif)#
atm pvc 10 0 10 aal5snap 0 0 0
host1(config-subif)#
ip address 10.10.10.1 255.255.255.0
!
! Enable MPLS, LDP, and topology-driven LSPs on the core-facing interface.
host1(config-subif)#
mpls
host1(config-subif)#
mpls ldp
host1(config-subif)#
exit
!
! Configure OSPF routing in the core MPLS network.
host1(config)#
router ospf 1
host1(config-router)#
network 1.1.1.1 0.0.0.0 area 0.0.0.0
host1(config-router)#
network 10.10.10.0 0.0.0.255 area 0.0.0.0
host1(config-router)#
exit
Configuration on PE 2 (Remote PE Router)
Use the following commands on the remote PE router (PE 2) to configure the VPLS
topology shown in Figure 130 on page 609.
610
■
VPLS Configuration Example with LDP Signaling
JUNOSe 11.1.x BGP and MPLS Configuration Guide
Содержание BGP
Страница 6: ...vi ...
Страница 8: ...viii JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 37: ...Part 1 Border Gateway Protocol Configuring BGP Routing on page 3 Border Gateway Protocol 1 ...
Страница 38: ...2 Border Gateway Protocol JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 234: ...198 Monitoring BGP JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 236: ...200 Multiprotocol Layer Switching JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 350: ...314 Example Traffic Class Configuration for Differentiated Services JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 541: ... There is no no version See undebug ip mbgp Monitoring BGP MPLS VPNs 505 Chapter 5 Configuring BGP MPLS Applications ...
Страница 542: ...506 Monitoring BGP MPLS VPNs JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 544: ...508 Layer 2 Services Over MPLS JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 598: ...562 Multiple ATM Virtual Circuits over a Single Pseudowire Example JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 610: ...574 Virtual Private LAN Service JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 624: ...588 VPLS References JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 648: ...612 VPLS Configuration Example with LDP Signaling JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 680: ...644 Virtual Private Wire Service JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 724: ...688 Monitoring MPLS Forwarding Table for VPWS JUNOSe 11 1 x BGP and MPLS Configuration Guide ...
Страница 725: ...Part 6 Index Index on page 691 Index 689 ...
Страница 726: ...690 Index JUNOSe 11 1 x BGP and MPLS Configuration Guide ...