390
The output shows that the MCE has learned the private route of VPN 2. The MCE maintains the
routes of VPN 1 and those of VPN 2 in two different routing tables. In this way, routes from
different VPNs are separated.
3.
Configure routing between the MCE and PE 1.
# On the MCE, configure the port connected to the PE 1 as a trunk port, and configure it to permit
packets of VLAN 30 and VLAN 40 to pass with VLAN tags.
[MCE] interface GigabitEthernet 3/0/3
[MCE-GigabitEthernet3/0/3] port link-type trunk
[MCE-GigabitEthernet3/0/3] port trunk permit vlan 30 40
[MCE-GigabitEthernet3/0/3] quit
# On PE 1, configure the port connected to MCE as a trunk port, and configure it to permit packets
of VLAN 30 and VLAN 40 to pass with VLAN tags.
<PE1> system-view
[PE1] interface GigabitEthernet 3/0/1
[PE1-GigabitEthernet3/0/1] port link-type trunk
[PE1-GigabitEthernet3/0/1] port trunk permit vlan 30 40
[PE1-GigabitEthernet3/0/1] quit
# On the MCE, create VLAN 30 and VLAN-interface 30, bind VLAN-interface 30 with VPN
instance
vpn1
and configure an IPv6 address for the VLAN-interface 30.
[MCE] vlan 30
[MCE-vlan30] quit
[MCE] interface vlan-interface 30
[MCE-Vlan-interface30] ip binding vpn-instance vpn1
[MCE-Vlan-interface30] ipv6 address 30::1 64
[MCE-Vlan-interface30] quit
# On the MCE, create VLAN 40 and VLAN-interface 40, bind VLAN-interface 40 with VPN
instance
vpn2
and configure an IPv6 address for the VLAN-interface 40.
[MCE] vlan 40
[MCE-vlan40] quit
[MCE] interface vlan-interface 40
[MCE-Vlan-interface40] ip binding vpn-instance vpn2
[MCE-Vlan-interface40] ipv6 address 40::1 64
[MCE-Vlan-interface40] quit
# On PE 1, create VLAN 30 and VLAN-interface 30, bind VLAN-interface 30 with VPN instance
vpn1
and configure an IPv6 address for the VLAN-interface 30.
[PE1] vlan 30
[PE1-vlan30] quit
[PE1] interface vlan-interface 30
[PE1-Vlan-interface30] ip binding vpn-instance vpn1
[PE1-Vlan-interface30] ipv6 address 30::2 64
[PE1-Vlan-interface30] quit
# On PE 1, create VLAN 40 and VLAN-interface 40, bind VLAN-interface 40 with VPN instance
vpn2
and configure an IPv6 address for the VLAN-interface 40.
[PE1] vlan 40
[PE1-vlan40] quit
[PE1] interface vlan-interface 40
[PE1-Vlan-interface40] ip binding vpn-instance vpn2