24-15
Catalyst 2360 Switch Software Configuration Guide
OL-19808-01
Chapter 24 Managing Network Security with ACLs
Configuring IPv4 ACLs
Switch(config)#
access-list 102 permit tcp any 128.88.0.0 0.0.255.255 eq 23
Switch(config)#
access-list 102 permit tcp any 128.88.0.0 0.0.255.255 eq 25
Switch(config)#
interface vlan 1
Switch(config-if)#
ip access-group 102 in
Named ACL
This example creates an extended ACL named
marketing_group
. The
marketing_group
ACL allows any
TCP Telnet traffic to the destination address and wildcard 171.69.0.0 0.0.255.255 and denies any other
TCP traffic. It permits any other IP traffic.
Switch(config)#
ip access-list extended marketing_group
Switch(config-ext-nacl)#
permit tcp any 171.69.0.0 0.0.255.255 eq telnet
Switch(config-ext-nacl)#
deny tcp any any
Switch(config-ext-nacl)#
permit ip any any
Switch(config-ext-nacl)#
exit
The
marketing_group
ACL is applied to incoming traffic on a port.
Switch(config)#
interface vlan 1
Switch(config-if)#
ip access-group marketing_group in
Time Range Applied to an IP ACL
This example denies HTTP traffic on IP on Monday through Friday between the hours of 8:00 a.m. and
6:00 p.m (18:00). The example allows UDP traffic only on Saturday and Sunday from noon to 8:00 p.m.
(20:00).
Switch(config)#
time-range no-http
Switch(config)#
periodic weekdays 8:00 to 18:00
!
Switch(config)#
time-range udp-yes
Switch(config)#
periodic weekend 12:00 to 20:00
!
Switch(config)#
ip access-list extended strict
Switch(config-ext-nacl)#
deny tcp any any eq www time-range no-http
Switch(config-ext-nacl)#
permit udp any any time-range udp-yes
!
Switch(config-ext-nacl)#
exit
Switch(config)#
interface vlan 1
Switch(config-if)#
ip access-group strict in
Commented IP ACL Entries
In this example of a numbered ACL, the workstation that belongs to Jones is allowed access, and the
workstation that belongs to Smith is not allowed access:
Switch(config)#
access-list 1 remark Permit only Jones workstation through
Switch(config)#
access-list 1 permit 171.69.2.88
Switch(config)#
access-list 1 remark Do not allow Smith workstation through
Switch(config)#
access-list 1 deny 171.69.3.13
In this example of a numbered ACL, the Winter and Smith workstations are not allowed to browse the
web:
Switch(config)#
access-list 100 remark Do not allow Winter to browse the web
Switch(config)#
access-list 100 deny host 171.69.3.85 any eq www
Switch(config)#
access-list 100 remark Do not allow Smith to browse the web
Switch(config)#
access-list 100 deny host 171.69.3.13 any eq www
Содержание Catalyst 2360
Страница 28: ...xxviii Catalyst 2360 Switch Software Configuration Guide OL 19808 01 Preface ...
Страница 200: ...9 24 Catalyst 2360 Switch Software Configuration Guide OL 19808 01 Chapter 9 Configuring VLANs Configuring VLAN Trunks ...
Страница 388: ...23 18 Catalyst 2360 Switch Software Configuration Guide OL 19808 01 Chapter 23 Configuring SNMP Displaying SNMP Status ...