3.
# Configure Switch B
switch(config)# router bgp 65009
switch(bgp)# bgp router-id 2.2.2.2
switch(bgp)# neighbor 3.3.3.3 remote-as 65009
switch(bgp)# exit
switch(config)# router ospf
switch(ospf)# enable
switch(ospf)# area 0
switch(ospf)# network 2.2.2.2/32
switch(ospf)# network 9.1.1.1/24
switch(ospf)# exit
switch(config)# vlan 300
switch(vlan-300)# ip ospf
4.
# Configure Switch C
switch(config)# router bgp 65009
switch(bgp)# bgp router-id 3.3.3.3
switch(bgp)# neighbor 2.2.2.2 remote-as 65009
switch(bgp)# neighbor 2.2.2.2 connect-interface loopback 0
switch(bgp)# exit
switch(config)# router ospf
switch(ospf)# enable
switch(ospf)# area 0
switch(ospf)# network 3.3.3.3/32
switch(ospf)# network 9.1.1.0/24
switch(ospf)# exit
switch(config)# vlan 300
switch(vlan-300)# ip ospf
switch(vlan-300)# show ip bgp summary
Peer Information
Remote Address Remote-AS Local-AS State Admin Status
-------------- --------- -------- ------------ -----
2.2.2.2 65009 65009 Established Start
5.
The output information shows that Switch C has established an iBGP peer relationship with Switch B.
6.
Configure eBGP.
a.
The eBGP peers, Switch A and Switch B (usually belonging to different carriers), are located in different
ASs. Their loopback interfaces are not reachable to each other, so directly connected interfaces are used
for establishing BGP sessions.
b.
To enable Switch C to access the network 8.1.1.0/24 that is connected directly to Switch A, add network
8.1.1.0/24 to the BGP routing table of Switch A.
7.
# Configure Switch A.
switch(config)# router bgp 65008
switch(bgp)# bgp router-id 1.1.1.1
switch(bgp)# neighbor 3.1.1.1 remote-as 65009
switch(bgp)# network 8.1.1.1/24
switch(bgp)# exit
8.
# Configure Switch B.
Chapter 17 Border Gateway Protocol (BGP)
389