419
Device
Interface
IP address
Device
Interface
IP address
GE1/1/1
10.2.2.1/24
Configuration procedure
1.
Configure CE 1.
<CE1> system-view
[CE1] interface gigabitethernet 1/1/1
[CE1-GigabitEthernet1/1/1] ip address 100.1.1.1 24
[CE1-GigabitEthernet1/1/1] quit
2.
Configure PE 1:
# Configure an LSR ID.
<PE1> system-view
[PE1] interface loopback 0
[PE1-LoopBack0] ip address 192.2.2.2 32
[PE1-LoopBack0] quit
[PE1] mpls lsr-id 192.2.2.2
# Enable L2VPN.
[PE1] l2vpn enable
# Enable global LDP.
[PE1] mpls ldp
[PE1-ldp] quit
# Configure the default next hop IP address as 100.1.1.1 on GigabitEthernet 1/1/1 (the interface
connected to CE 1. This interface does not need an IP address.
[PE1] interface gigabitethernet 1/1/1
[PE1-GigabitEthernet1/1/1] default-nexthop ip 100.1.1.1
[PE1-GigabitEthernet1/1/1] quit
# Configure GigabitEthernet 1/1/2 (the interface connected to the P device), and enable LDP on
the interface.
[PE1] interface gigabitethernet 1/1/2
[PE1-GigabitEthernet1/1/2] ip address 10.1.1.1 24
[PE1-GigabitEthernet1/1/2] mpls enable
[PE1-GigabitEthernet1/1/2] mpls ldp enable
[PE1-GigabitEthernet1/1/2] quit
# Configure OSPF for LDP to create LSPs.
[PE1] ospf
[PE1-ospf-1] area 0
[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255
[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0
[PE1-ospf-1-area-0.0.0.0] quit
[PE1-ospf-1] quit
# Create a cross-connect group named
vpna
, create a cross-connect named
ldp
in the group,
enable interworking for the cross-connect, and bind GigabitEthernet 1/1/1 to the cross-connect.
[PE1] xconnect-group vpna
[PE1-xcg-vpna] connection ldp
[PE1-xcg-vpna-ldp] interworking ipv4
[PE1-xcg-vpna-ldp] ac interface gigabitethernet 1/1/1
# Create an LDP PW for the cross-connect to bind the AC to the PW.