300
# Enable IP multicast routing on the public network, configure an MPLS LSR ID, and enable the
LDP capability.
<P> system-view
[P] multicast routing-enable
[P] mpls lsr-id 2.2.2.2
[P] mpls
[P-mpls] quit
[P] mpls ldp
[P-mpls-ldp] quit
# Assign an IP address to VLAN-interface 30, and enable PIM-SM and LDP capability on the
interface.
[P] interface vlan-interface 30
[P-Vlan-interface30] ip address 192.168.1.2 24
[P-Vlan-interface30] pim sm
[P-Vlan-interface30] mpls
[P-Vlan-interface30] mpls ldp
[P-Vlan-interface30] quit
# Assign an IP address to VLAN-interface 40, and enable PIM-SM and LDP capability on the
interface.
[P] interface vlan-interface 40
[P-Vlan-interface40] ip address 192.168.2.1 24
[P-Vlan-interface40] pim sm
[P-Vlan-interface40] mpls
[P-Vlan-interface40] mpls ldp
[P-Vlan-interface40] quit
# Assign an IP address to Loopback 1, and enable PIM-SM on the interface.
[P] interface loopback 1
[P-LoopBack1] ip address 2.2.2.2 32
[P-LoopBack1] pim sm
[P-LoopBack1] quit
# Configure Loopback 1 as a C-BSR and a C-RP for the public network.
[P] pim
[P-pim] c-bsr loopback 1
[P-pim] c-rp loopback 1
[P-pim] quit
# Configure OSPF.
[P] ospf 1
[P-ospf-1] area 0.0.0.0
[P-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
[P-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
[P-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
4.
Configure CE
a1
:
# Enable IPv6 forwarding and IPv6 multicast routing.
<CEa1> system-view
[CEa1] ipv6
[CEa1] multicast ipv6 routing-enable
# Assign an IPv6 address to VLAN-interface 10 and enable IPv6 PIM-SM on the interface.
[CEa1] interface vlan-interface 10