4-22
VPN Acceleration Module 2+ (VAM2+) Installation and Configuration Guide
OL-5979-03
Chapter 4 Configuring the SA-VAM2+
Basic IPSec Configuration Illustration
The crypto map is applied to an interface:
interface Serial0
ip address 10.0.0.2
crypto map toRemoteSite
Note
In this example, IKE must be enabled.
Configuring Compression Example
The following example shows a simple configuration example for configuring compression.
To configure an IKE policy:
crypto isakmp policy 1
hash md5
authentication pre-share
group 2
To configure a IKE preshared key:
crypto isakmp key 12abcjhrweit345 address 16.0.0.2
To configure an ipsec transform set:
crypto ipsec transform-set proposal_01 esp-3des esp-md5-hmac comp-lzs
To configure an access-list:
access-list 101 permit ip host 16.0.0.1 host 16.0.0.2
To configure a crypto map:
crypto map MAXCASE 10 ipsec-isakmp
set peer 16.0.0.2
set transform-set proposal_01
match address 101
To apply crypto map to the interface:
interface FastEthernet1/0
crypto map MAXCASE
Basic IPSec Configuration Illustration
The following is an example of an IPSec configuration in which the security associations are established
through IKE. In this example an access list is used to restrict the packets that are encrypted and
decrypted. In this example, all packets going from IP address 10.0.0.2 to IP address 10.2.2.2 are
encrypted and decrypted and all packets going from IP address 10.2.2.2 to IP address 10.0.0.2 are
encrypted and decrypted. Also, one IKE policy is created.