ZXR10 ZSR V2 Configuration Guide (IPv6)
Configuration Commands
The IPv6 interface address configuration is omitted in this example. For the detailed
configuration, refer to “Example: Configuring BGP4+ Route Load Sharing”.
Configuration on R4:
R4(config)#router bgp 2
R4(config-bgp)#neighbor 2001::1 remote-as 1
R4(config-bgp)#address-family ipv6
R4(config-bgp-af-ipv6)#neighbor 2001::1 activate
R4(config-bgp-af-ipv6)#redistribute static
/*config redistribute static route*/
R4(config-bgp-af-ipv6)#end
Configuration on R1:
R1(config)#router bgp 1
R1(config-bgp)#neighbor 2003::2
remote-as 1
R1(config-bgp)#neighbor 2001::4
remote-as 2
R1(config-bgp)#address-family ipv6
R1(config-bgp-af-ipv6)#neighbor 2001::4 activate
R1(config-bgp-af-ipv6)#neighbor 2003::2 activate
R1(config-bgp-af-ipv6)#end
Configuration on R2:
R2(config)#router bgp 1
R2(config-bgp)#neighbor 2003::1 remote-as 1
R2(config-bgp)#neighbor 2007::5 remote-as 3
R2(config-bgp)#neighbor 2007::5 ebgp-multihop
/*config ebgp-multihop*/
R2(config-bgp)#neighbor 2007::5 password hello
/*config password*/
R2(config-bgp)#address-family ipv6
R2(config-bgp-af-ipv6)#neighbor 2003::1 activate
R2(config-bgp-af-ipv6)#neighbor 2007::5 activate
R2(config-bgp-af-ipv6)#end
Configuration on R3:
R5(config)#router bgp 3
R3(config-bgp)#neighbor 2005::2 remote-as 1
R3(config-bgp)#neighbor 2005::2 ebgp-multihop
R3(config-bgp)#neighbor 2005::2 password hello
R3(config-bgp)#address-family ipv6
R3(config-bgp-af-ipv6)#neighbor 2005::2 activate
R3(config-bgp-af-ipv6)#end
Configuration Verification
Run the
show bgp ipv6 unicast summary
command on R1 to check the adjacency, as shown
below.
8-8
SJ-20140504150128-018|2014-05-10 (R1.0)
ZTE Proprietary and Confidential