undo shutdown
port link-type access
port default vlan 10
#
return
l
Configuration file of Router B
#
sysname RouterA
#
interface GigabitEthernet1/0/0
undo shutdown
ip address 20.1.1.3 255.255.255.0
#
return
l
Configuration file of Router C
#
sysname RouterB
#
interface GigabitEthernet1/0/0
undo shutdown
ip address 20.1.1.4 255.255.255.0
#
return
l
Configuration file of Router D
#
sysname RouterC
#
arp vlink-direct-route advertise route-policy policy1
#
vlan batch 10
#
interface Vlanif10
ip address 20.1.1.1 255.255.255.0
#
interface GigabitEthernet1/0/0
portswitch
undo shutdown
port link-type access
port default vlan 10
#
interface GigabitEthernet2/0/0
undo shutdown
ip address 20.2.1.1 255.255.255.0
#
bgp 100
router-id 3.3.3.3
peer 20.2.1.2 as-number 100
#
ipv4-family unicast
undo synchronization
import-route direct
peer 20.2.1.2 enable
peer 20.2.1.2 route-policy policy2 export
#
route-policy policy1 permit node 10
if-match ip-prefix prefix1
#
route-policy policy2 permit node 10
if-match ip-prefix prefix2
#
ip ip-prefix prefix1 index 10 permit 20.1.1.4 32
ip ip-prefix prefix2 index 10 deny 20.1.1.0 24
ip ip-prefix prefix2 index 20 permit 0.0.0.0 0 less-equal 32
HUAWEI NetEngine80E/40E Router
Configuration Guide - IP Routing
1 IP Routing Basic Configuration
Issue 02 (2014-09-30)
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
78