
222
[NPE1-GigabitEthernet2/1/1] quit
# Configure basic MPLS on GigabitEthernet 2/1/2, the interface connected to NPE 3.
[NPE1] interface gigabitethernet 2/1/2
[NPE1-GigabitEthernet2/1/2] ip address 11.1.1.1 24
[NPE1-GigabitEthernet2/1/2] mpls
[NPE1-GigabitEthernet2/1/2] mpls ldp
[NPE1-GigabitEthernet2/1/2] quit
# Configure the remote LDP peer UPE.
[NPE1] mpls ldp remote-peer 2
[NPE1-mpls-remote-2] remote-ip 1.1.1.9
[NPE1-mpls-remote-2] quit
# Configure the remote LDP peer NPE 3.
[NPE1] mpls ldp remote-peer 3
[NPE1-mpls-remote-3] remote-ip 3.3.3.9
[NPE1-mpls-remote-3] quit
# Enable L2VPN and MPLS L2VPN.
[NPE1] l2vpn
[NPE1-l2vpn] mpls l2vpn
[NPE1-l2vpn] quit
# Create VPLS instance
aaa
that uses LDP signaling.
[NPE1] vsi aaa static
[NPE1-vsi-aaa] pwsignal ldp
[NPE1-vsi-aaa-ldp] vsi-id 500
[NPE1-vsi-aaa-ldp] peer 1.1.1.9 upe
[NPE1-vsi-aaa-ldp] peer 3.3.3.9
[NPE1-vsi-aaa-ldp] quit
[NPE1-vsi-aaa] quit
4.
Configure NPE 3:
# Configure basic MPLS.
<Sysname> system-view
[Sysname] sysname NPE3
[NPE3] interface loopback 0
[NPE3-LoopBack0] ip address 3.3.3.9 32
[NPE3-LoopBack0] quit
[NPE3] mpls lsr-id 3.3.3.9
[NPE3] mpls
[NPE3–mpls] quit
[NPE3] mpls ldp
[NPE3–mpls-ldp] quit
# Configure basic MPLS on GigabitEthernet 2/1/2, the interface connected to NPE 1.
[NPE3] interface gigabitethernet 2/1/2
[NPE3-GigabitEthernet2/1/2] ip address 11.1.1.2 24
[NPE3-GigabitEthernet2/1/2] mpls
[NPE3-GigabitEthernet2/1/2] mpls ldp
[NPE3-GigabitEthernet2/1/2] quit
# Configure the remote LDP peer.
[NPE3] mpls ldp remote-peer 1