16- and 36-Port Ethernet Switch Module for Cisco 2600 Series, Cisco 3600 Series, and Cisco 3700 Series
Configuration Examples for the 16- and 36-Port Ethernet Switch Module
144
Cisco IOS Release 12.2(2)XT, 12.2(8)T, and 12.2(15)ZJ
The following example uses an extended ACL to deny traffic from port 80 (HTTP). It permits all other
types of traffic:
Switch(config)#
access-list 106 deny tcp any any eq 80
Switch(config)#
access-list 106 permit ip any any
Switch(config)#
interface gigabitethernet0/2
Switch(config-if)#
ip access-group 106 in
QoS Configuration Examples
•
Classifying Traffic by Using ACL Example, page 144
•
Classifying Traffic by Using Class Maps Example, page 144
•
Classifying, Policing, and Marking Traffic by Using Policy Maps Example, page 144
•
Configuring the CoS-to-DSCP Map Example, page 145
•
Configuring the DSCP-to-CoS Map Example, page 145
•
Displaying QoS Information Example, page 145
Classifying Traffic by Using ACL Example
The following example shows how to allow access for only those hosts on the two specified networks.
The wildcard bits apply to the host portions of the network addresses. Any host with a source address
that does not match the ACL statements is rejected.
Switch(config)#
access-list 1 permit 192.5.255.0 0.0.0.255
Switch(config)#
access-list 1 permit 36.0.0.0 0.0.0.255
Classifying Traffic by Using Class Maps Example
The following example shows how to configure the class map called class1. The class1 has one match
criterion, which is an ACL called 103.
Switch(config)#
access-list 103 permit any any tcp eq 80
Switch(config)#
class-map class1
Switch(config-cmap)#
match access-group 103
Switch(config-cmap)#
end
Switch#
Classifying, Policing, and Marking Traffic by Using Policy Maps Example
The following example shows how to create a policy map and attach it to an ingress interface. In the
configuration, the IP standard ACL permits traffic from network 10.1.0.0. For traffic matching this
classification, the DSCP value in the incoming packet is trusted. If the matched traffic exceeds an
average traffic rate of 48000 bps and a normal burst size of 8000 bytes, its DSCP is marked down to a
value of 10 and transmitted.
Switch(config)#
access-list 1 permit 10.1.0.0 0.0.255.255
Switch(config)#
class-map ipclass1
Switch(config-cmap)#
match access-group 1
Switch(config-cmap)#
exit
Switch(config)#
policy-map flow1t
Switch(config-pmap)#
class ipclass1
Switch(config-pmap-c)#
police 5000000 8192 exceed-action dscp 10
Switch(config-pmap-c)#
exit