4.
Configure tunnel policies and apply the tunnel policies to the VPN instances.
5.
Configure MP-IBGP for exchanging routing information between the VPNs.
Data Preparation
To complete the configuration, you need the following data:
l
MPLS LSR IDs of the PEs
l
Names, RDs, and VPN targets of the two VPN instances
l
Names of the two tunnel policies
Procedure
Step 1
Enable the IGP protocol on the MPLS backbone network to ensure IP interworking between the
PEs.
# Configure PE1.
<Quidway>
system-view
[Quidway]
sysname PE1
[PE1]
interface loopback 1
[PE1-LoopBack1]
ip address 1.1.1.1 32
[PE1-LoopBack1]
quit
[PE1]
vlan 10
[PE1-vlan10]
quit
[PE1]
interface gigabitethernet 1/0/1
[PE1-GigabitEthernet1/0/1]
port hybrid pvid vlan 10
[PE1-GigabitEthernet1/0/1]
port hybrid untagged vlan 10
[PE1-GigabitEthernet1/0/1]
quit
[PE1]
interface vlanif 10
[PE1-Vlanif10]
ip address 100.1.1.1 30
[PE1-Vlanif10]
quit
[PE1]
ospf 1
[PE1-ospf-1]
area 0
[PE1-ospf-1-area-0.0.0.0]
network 100.1.1.0 0.0.0.3
[PE1-ospf-1-area-0.0.0.0]
network 1.1.1.1 0.0.0.0
[PE1-ospf-1-area-0.0.0.0]
quit
[PE1-ospf-1]
quit
# Configure PE2.
<Quidway>
system-view
[Quidway]
sysname PE2
[PE2]
interface loopback 1
[PE2-LoopBack1]
ip address 2.2.2.2 32
[PE2-LoopBack1]
quit
[PE2]
vlan 10
[PE2-vlan10]
quit
[PE2]
interface gigabitethernet 1/0/1
[PE2-GigabitEthernet1/0/1]
port hybrid pvid vlan 10
[PE2-GigabitEthernet1/0/1]
port hybrid untagged vlan 10
[PE2-GigabitEthernet1/0/1]
quit
[PE2]
interface vlanif 10
[PE2-Vlanif10]
ip address 100.1.1.2 30
[PE2-Vlanif10]
quit
[PE2]
ospf 1
[PE2-ospf-1]
area 0
[PE2-ospf-1-area-0.0.0.0]
network 100.1.1.0 0.0.0.3
[PE2-ospf-1-area-0.0.0.0]
network 2.2.2.2 0.0.0.0
[PE2-ospf-1-area-0.0.0.0]
quit
[PE2-ospf-1]
quit
# By running the
display ip routing-table
command on the PEs, you can see that the PEs can
learn the routes of each other's Loopback1 interface.
Quidway S7700 Smart Routing Switch
Configuration Guide - VPN
1 VPN Tunnel Management Configuration
Issue 01 (2011-07-15)
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
31