Procedure
Step 1
Import flows from the switch to the SPU.
# Configure the switch.
[Switch]
sysname Switch
[Switch]
vlan 10
[Switch-vlan10]
quit
[Switch]
interface gigabitethernet 1/0/4
[Switch-GigabitEthernet1/0/4]
port link-type access
[Switch-GigabitEthernet1/0/4]
port default vlan 10
[Switch-GigabitEthernet1/0/4]
quit
[Switch]
vlan 20
[Switch-vlan20]
quit
[Switch]
interface gigabitethernet 1/0/6
[Switch-GigabitEthernet1/0/6]
port link-type access
[Switch-GigabitEthernet1/0/6]
port default vlan 20
[Switch-GigabitEthernet1/0/6]
quit
[Switch]
interface eth-trunk 0
[Switch-Eth-Trunk0]
port link-type trunk
[Switch-Eth-Trunk0]
undo port trunk allow-pass vlan 1
[Switch-Eth-Trunk0]
port trunk allow-pass vlan 10 20
[Switch-Eth-Trunk0]
quit
[Switch]
interface xgigabitethernet 2/0/0
[Switch-XGigabitEthernet2/0/0]
eth-trunk 0
[Switch-XGigabitEthernet2/0/0]
quit
[Switch]
interface xgigabitethernet 2/0/1
[Switch-XGigabitEthernet2/0/1]
eth-trunk 0
[Switch-XGigabitEthernet2/0/1]
quit
# Configure the SPU on the switch.
[Quidway]
sysname SPU
[SPU]
interface eth-trunk 0
[SPU]
interface xgigabitethernet 0/0/1
[SPU-XGigabitEthernet0/0/1]
eth-trunk 0
[SPU]
interface xgigabitethernet 0/0/2
[SPU-XGigabitEthernet0/0/2]
eth-trunk 0
Step 2
Configure a VPN instance on the SPU.
[SPU]
ip vpn-instance vpn-a
[SPU-vpn-instance-vpn-a]
route-distinguisher 1:1
[SPU-vpn-instance-vpn-a]
vpn-target 1:1
[SPU-vpn-instance-vpn-a]
quit
[SPU]
ip vpn-instance vpn-b
[SPU-vpn-instance-vpn-b]
route-distinguisher 2:2
[SPU-vpn-instance-vpn-b]
vpn-target 2:2
[SPU-vpn-instance-vpn-b]
quit
Step 3
Create sub-interfaces on the SPU and bind the VPN instance to the sub-interfaces.
[SPU]
interface eth-trunk 0.10
[SPU-Eth-Trunk0.10]
control-vid 10 dot1q-termination
[SPU-Eth-Trunk0.10]
dot1q termination vid 10
[SPU-Eth-Trunk0.10]
ip binding vpn-instance vpn-a
[SPU-Eth-Trunk0.10]
ip address 10.10.10.2 24
[SPU-Eth-Trunk0.10]
arp broadcast enable
[SPU-Eth-Trunk0.10]
quit
[SPU]
interface eth-trunk 0.20
[SPU-Eth-Trunk0.20]
control-vid 20 dot1q-termination
[SPU-Eth-Trunk0.20]
dot1q termination vid 20
[SPU-Eth-Trunk0.20]
ip binding vpn-instance vpn-b
[SPU-Eth-Trunk0.20]
ip address 20.20.20.2 24
[SPU-Eth-Trunk0.20]
arp broadcast enable
[SPU-Eth-Trunk0.20]
quit
Step 4
Configure the static route on the SPU to allow the VPNs to communicate with each other.
Quidway S7700 Smart Routing Switch
Configuration Guide - VPN
3 BGP MPLS IP VPN Configuration
Issue 01 (2011-07-15)
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
202