Data Preparation
To complete the configuration, you need the following data:
l
Interfaces used to connect LANs
l
Number of each bridge group to which the LANs that need to communicate with each other
are added
Configuration Procedure
l
Configure the IP routing function.
1.
Configure RouterA.
# Create bridge group 1 and bridge group, then enable the IP routing function for the
bridge groups.
<Huawei>
system-view
[Huawei]
sysname RouterA
[RouterA]
bridge 1
[RouterA-bridge1]
routing ip
[RouterA-bridge1]
quit
[RouterA]
bridge 2
[RouterA-bridge2]
routing ip
[RouterA-bridge2]
quit
# Add Eth2/0/1 and Eth2/0/2 to VLAN 11 to allow the communication between User
1 and User 2.
[RouterA]
vlan 11
[RouterA-vlan11]
quit
[RouterA]
interface ethernet 2/0/1
[RouterA-Ethernet2/0/1]
port link-type access
[RouterA-Ethernet2/0/1]
port default vlan 11
[RouterA-Ethernet2/0/1]
quit
[RouterA]
interface ethernet 2/0/2
[RouterA-Ethernet2/0/2]
port link-type access
[RouterA-Ethernet2/0/2]
port default vlan 11
[RouterA-Ethernet2/0/2]
quit
#Add VLANIF 11 to bridge group 1.
[RouterA]
interface vlanif 11
[RouterA-Vlanif11]
bridge 1
[RouterA-Vlanif11]
quit
# Add GE3/0/0 on Router A to bridge group 2.
[RouterA]
interface gigabitethernet 3/0/0
[RouterA-GigabitEthernet3/0/0]
bridge 2
[RouterA-GigabitEthernet3/0/0]
quit
# Create Bridge-if interface 1 for bridge group 1 and Bridge-if interface 2 for bridge
group 2, and then configure IP addresses for the two Bridge-if interfaces.
[RouterA]
interface bridge-if 1
[RouterA-Bridge-if1]
ip address 1.1.1.3 255.255.255.0
[RouterA-Bridge-if1]
quit
[RouterA]
interface bridge-if 2
[RouterA-Bridge-if2]
ip address 2.1.1.3 255.255.255.0
[RouterA-Bridge-if2]
quit
2.
Configure RouterB.
# Create bridge group 2 and enable the IP routing function for the bridge groups.
<Huawei>
system-view
[Huawei]
sysname RouterB
[RouterB]
bridge 2
[RouterB-bridge2]
routing ip
[RouterB-bridge2]
quit
Huawei AR3200 Series Enterprise Routers
Configuration Guide - LAN
2 Transparent Bridging Configuration
Issue 02 (2012-03-30)
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
71