HES7000 ICLI User’s Guide A01583 Rev. A
Page
31
of 37
6.1. show running-config
The virtual file
running-config
consists of a list of commands that, taken together, result in the
currently running system configuration.
This list of commands is usually not 100% identical to the list of commands a user has input
to configure the device. That is because
running-config
is a textual representation of the
system configuration which is stored in binary form in the RAM memory of the device.
Since the effective device configuration is huge,
running-config
in the majority of cases only
lists the delta between default settings and current settings. This significantly reduces the
amount of output and greatly improves readability of the configuration, but it does require the
reader to know what the default settings are.
With
show running-config all-defaults
it is possible to include values that are at default.
Example 12. Default vs. Non-default vs. All Defaults
In this example if the speed and duplex settings of an Ethernet interface are at default values
(auto-negotiation) then nothing will be output. If the user then changes the speed to be fixed
at 1 Gbps then that value is now non-default and will be output. Duplex is also output, since it
is forced to ‘full’ when the speed is fixed at 1 Gbps.
Display current configuration for an interface. All settings are at default:
myDevice#
show running-config interface GigabitEthernet 1/4
Building configuration
…
interface GigabitEthernet 1/4
!
end
Now set the speed to 1Gbps and display the configuration again: myDevice#
configure
terminal
myDevice(config)#
interface GigabitEthernet 1/4
myDevice(config-if)#
speed 1000
myDevice(config-if)#
end
myDevice#
show running-config interface GigabitEthernet 1/4
Building configuration...
interface GigabitEthernet 1/4
speed 1000
duplex full
!
end
Include all default settings for that interface:
myDevice
# show running-config interface GigabitEthernet 1/4 all-defaults
Building configuration...
interface GigabitEthernet 1/4
switchport voice vlan mode disable
no switchport voice vlan security
switchport voice vlan discovery-protocol oui
loop-protect
no loop-protect action
loop-protect tx-mode
switchport access vlan 1
switchport trunk native vlan 1
switchport hybrid native vlan 1
switchport trunk allowed vlan 1-4095
... much output omitted for brevity ...
Note how the output of
show running-config
can be restricted to a specific interface. There
are several such filters, described below.
Summary of Contents for HES7000
Page 1: ...HES7000 ICLI USER S GUIDE A01583 Rev A ...
Page 3: ...HES7000 ICLI User s Guide A01583 Rev A ...
Page 4: ......