Deploying FCoE (FIP Snooping) on Dell Force 10 MXL
40
Step by step explanation of CLI example (only covering the differences from the single port
configuration)
o
interface port-channel1
switchport mode trunk -
switchport trunk native vlan 20
switchport trunk allowed vlan 1000
1000
o
interface vfc1 –
selects virtual fc interface vfc1 (vfc1 is an example and can be a different number
based on choice at configuration time)
bind interface port-channel1 –
this binds interface port-channel1 to the virtual fc interface
which in this case is vfc1.
no shutdown –
turns the virtual interface on since default is shutdown.
o
interface Ethernet 1/1 –
selects interface Ethernet 1/1.
switchport mode trunk –
set switchport mode to trunk for the 2 VLAN’s.
switchport trunk native vlan 20 –
add native VLAN 20 to the trunk.
switchport trunk allowed vlan 1000 –
add allowed VLAN 1000 to the trunk.
channel-group 1 mode active –
this interface is part of a port channel 1.
o
interface Ethernet 1/2 –
selects interface Ethernet ½.
switchport mode trunk –
set switchport mode to trunk for the 2 VLAN’s.
switchport trunk native vlan 20 –
add native VLAN 20 to the trunk.
switchport trunk allowed vlan 1000 –
add allowed VLAN 1000 to the trunk.
channel-group 1 mode active –
this interface is part of port channel 1.
o
zone name blade1 vsan 2 –
this will set the name for your zone (blade1 can be any chosen name),
vsan 2 will match the vsan you have created.
member interface fc2/15 -
this adds the fc2/15 interface as a member of the zone.
member pwwn xx:xx:xx:xx:xx:xx:xx:xx –
adds the port WWN of the ENode device to the zone
(this should match the CNA of the server being used, in this case blade 2).
o
zone name blade2 vsan 2 –
this will set the name for your zone (blade1 can be any chosen name),
vsan 2 will match the vsan you have created.
member interface fc2/16 -
this adds the fc2/16 interface as a member of the zone.
member pwwn xx:xx:xx:xx:xx:xx:xx:xx –
adds the port WWN of the ENode device to the zone
(this should match the CNA of the server being used, in this case blade 2).
o
zoneset name set1 vsan 2 –
move into the zoneset interface (in this case the name is set1 but
could be any name and the VSAN number is based on the FCoE VLAN being used.
o
member blade1 –
this includes the blade1 zone into this zoneset
o
member blade2 –
this includes the blade2 zone into this zoneset
o
zoneset activate name set1 vsan 2 –
activates the zoneset containing these zones.