Deploying FCoE (FIP Snooping) on Dell Force 10 MXL
16
Step by step explanation of CLI example
o
configure –
this brings the prompt into the configuration interface.
o
feature fip-snooping
– This configures the global enablement of the FIP-Snooping feature on the
switch.
o
protocol lldp –
Sets the global enablement of LLDP on the switch.
o
service-class dynamic dot1p –
This sets the switch to globally honor dot1p priorities for traffic on
the switch.
o
default vlan-id 20 –
This established the default and native vlan for the switch (in this case 20 is
used).
o
interface TenGigabitEthernet 0/1 – configure internal interfaces that connect to the blade
servers.
portmode hybrid –
configuring portmode hybrid will allow for the native VLAN untagged,
and a tagged VLAN to exist on the port together. This is similar to switchport mode trunk in
industry standard CLI.
switchport –
this configures the port as a layer 2 port.
protocol lldp –
this moves into the lldp protocol settings.
dcbx port-role auto-downstream –
with this command the port-role is established
as a dcbx capable downstream port to communicate with blade server CNA ports.
spanning-tree pvst edge-port –
configure port as an edge port for spanning-tree behavior
no shutdown –
configures the port as active.
exit –
exits interface configuration mode
o
interface TenGigabitEthernet 0/52
portmode hybrid –
configuring portmode hybrid will allow for the native VLAN untagged,
and a tagged VLAN to exist on the port together. This is similar to switchport mode trunk in
industry standard CLI.
switchport –
this configures the port as a layer 2 port.
fip-snooping port-mode fcf –
enables the port for fip-snooping from an FCF connection
protocol lldp –
this moves into the lldp protocol settings.
no advertise dcbx-tlv ets-reco –
this settings establishes that the ETS
recommended configuration TLV’s should not be advertised for manual type
settings. Instead they should be determined via negotiations
dcbx port-role auto-upstream –
with this command the port-role is established as
a dcbx capable upstream port to communicate with top-of-rack FCF switches such
as the Cisco Nexus 5000 series.
no shutdown –
configures the port as active.
exit –
exits interface configuration mode
o
interface ManagementEthernet 0/0 –
steps into configuration of the management port for the
switch. Note that this port is a logical port connected through the CMC’s management port.
ip address 172.25.188.143/16 –
set IP address matching the infrastructure
no shutdown –
set port active
o
interface Vlan 20 –
Initializes VLAN 20 for use.
exit –
exits interface configuration mode
o
interface Vlan 1000 –
Initializes VLAN 1000 for use. This VLAN will be the FCoE VLAN that will pass
the storage traffic after the intial FIP negotiations occur on the native or default VLAN.