5-8
Cisco IR829 Integrated Services Router
Chapter 5 Guest Operating System (Guest OS) Installation and Configuration
Configuring NAT
Note
Ensure that the
PermitEmptyPasswords
parameter is set to
no
.
PermitRootLogin
yes
PasswordAuthentication
yes
PermitEmptyPasswords
no
Step 3
Restart SSHD:
[GOS]# /etc/init.d/
sshd stop
Stopping sshd: [ OK ]
[GOS]# /etc/init.d/
sshd start
Starting sshd: [ OK ]
[GOS]#
Step 4
From the IOS command line, enter the following:
IR800#
iox host exec enablessh IR800-GOS-1
ssh enabled successfully.
You now have remote SSH access to Guest OS.
Configuring NAT
The following example configuration uses NAT for Guest OS network connectivity, where:
•
9.1.1.0 is the externally reachable subnet.
•
9.1.1.131 is the external IP address made available for Guest OS access.
•
192.168.1.0 is the private subnet created for Guest OS to Cisco IOS connectivity. This is not directly
reachable outside the IR829.
•
The IP address acquired by Guest OS through IOS local DHCP pool is 192.168.1.2. This address
can be obtained using
show iox host list details
command from IOS.
ip dhcp pool gospool
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
domain-name utility.com
dns-server 9.1.1.1
lease 5
interface gig 5
ip nat inside
ip address 192.168.1.1 255.255.255.0
ipv6 enable
no shutdown
interface gig 0
ip nat outside
ip address 9.1.1.5 255.255.255.0
no shutdown
ip nat inside source static 192.168.1.2 9.1.1.131
! End of configuration
IR800#sh ip nat trans