
57
Fig 1-3 RIP example
In the figure shown above, a network consists of three Layer 3 switches, in which SwitchA
connected with SwitchB and SwitchC, and RIP routing protocol is running in all of the three
switches. SwitchA
(
interface vlan1
:
10.1.1.1,interface vlan2
:
20.1.1.1
)
exchanges Layer 3 switch
update messages only with SwitchB
(
interface vlan1
:
10.1.1.2
)
, but not with SwitchC
(
interface
vlan 2: 20.1.1.2
)
.
SwitchA, SwitchB, SwitchC configurations are as follows:
a) Layer 3 SwitchA
:
Configure the IP address of interface vlan 1
SwitchA#config
SwitchA(config)# interface vlan 1
SwitchA(Config-if-Vlan1)# ip address 10.1.1.1 255.255.255.0
SwitchA(config-if-Vlan1)#
Configure the IP address of interface vlan 2
SwitchA(config)# vlan 2
SwitchA(Config-Vlan2)# switchport interface ethernet 1/2
Set the port Ethernet1/2 access vlan 2 successfully
SwitchA(Config-Vlan2)# exit
SwitchA(config)# interface vlan 2
SwitchA(Config-if-Vlan2)# ip address 20.1.1.1 255.255.255.0
Initiate RIP protocol and configure the RIP segments
SwitchA(config)#router rip
SwitchA(config-router)#network vlan 1
SwitchA(config-router)#network vlan 2
SwitchA(config-router)#exit
Configure that the interface vlan 2 do not transmit RIP messages to SwitchC
SwitchA(config)#router rip
SwitchA(config-router)#passive-interface vlan 2
vlan2:20.1.1.1/24
SwitchA
SwitchC
Interface
Vlan2:20.1.1.2/24
Interface
vlan1:10.1.1.2/24
Interface
vlan1:10.1.1.1/24
Interface
SwitchB