
123
SwitchD(config-router)#exit
Configure simple key authentication.
SwitchD(config)#interface vlan 2
SwitchD(config-If-Vlan2)#ip ospf authentication
SwitchD(config-If-Vlan2)#ip ospf authentication-key DCS
SwitchD(config-If-Vlan2)#exit
Configure the IP address and the area number for the interface vlan 1
SwitchD(config)# interface vlan 1
SwitchD(config-If-Vlan1)# ip address 10.1.6.1 255.255.255.0
SwitchD(config-If-Vlan1)exit
SwitchD(config)#router ospf
SwitchD(config-router)#network 10.1.6.0/24 area 0
SwitchD(config-router)#exit
Configure MD5 key authentication
SwitchD(config)#interface vlan 1
SwitchD(config-If-Vlan1)#ip ospf authentication message-digest
SwitchD(config-If-Vlan1)#ip ospf authentication-key DCS
SwitchD(config-If-Vlan1)exit
SwitchD(config)#exit
1.6.4.2 Configuration Examples of OSPF VPN
Fig 1-9 OSPF VPN Example
The above figure shows that a network consists of three Layer 3 switches in which the switchA
as PE, SwitchB and SwitchC as CE1 and CE2. The PE is connected to CE1 and CE2 through
vlan1 and vlan2. The routing messages are exchanged between PE and CE through OSPF
protocol.
a) SwitchA, the Layer 3 switch as PE
vlan2:20.1.1.1/24
SwitchA
SwitchC
Interface
Vlan2:20.1.1.2/24
vlan1:10.1.1.2/24
Interface
vlan1:10.1.1.1/24
Interface
SwitchB