266
[P1-Vlan-interface3] quit
# Assign an IP address to Loopback 1, and enable PIM-SM on the interface.
[P1] interface loopback 1
[P1-LoopBack1] ip address 5.5.5.5 32
[P1-LoopBack1] pim sm
[P1-LoopBack1] quit
# Configure OSPF.
[P1] ospf 1
[P1-ospf-1] area 0.0.0.0
[P1-ospf-1-area-0.0.0.0] network 5.5.5.5 0.0.0.0
[P1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
[P1-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
6.
Configure P 2:
# Enable IP multicast routing on the public network.
<P2> system-view
[P2] multicast routing
[P2-mrib] quit
# Configure an LSR ID, and enable LDP globally.
[P2] mpls lsr-id 6.6.6.6
[P2] mpls ldp
[P2-ldp] quit
# Assign an IP address to VLAN-interface 6.
[P2] interface vlan-interface 6
[P2-Vlan-interface6] ip address 10.5.1.1 24
# Enable PIM-SM, MPLS, and IPv4 LDP on VLAN-interface 6.
[P2-Vlan-interface6] pim sm
[P2-Vlan-interface6] mpls enable
[P2-Vlan-interface6] mpls ldp enable
[P2-Vlan-interface6] quit
# Assign an IP address to VLAN-interface 5.
[P2] interface vlan-interface 5
[P2-Vlan-interface5] ip address 10.4.1.2 24
# Enable PIM-SM, MPLS, and IPv4 LDP on VLAN-interface 5.
[P2-Vlan-interface5] pim sm
[P2-Vlan-interface5] mpls enable
[P2-Vlan-interface5] mpls ldp enable
[P2-Vlan-interface5] quit
# Assign an IP address to Loopback 1, and enable PIM-SM on the interface.
[P2] interface loopback 1
[P2-LoopBack1] ip address 6.6.6.6 32
[P2-LoopBack1] pim sm
[P2-LoopBack1] quit
# Configure OSPF.
[P2] ospf 1
[P2-ospf-1] area 0.0.0.0
[P2-ospf-1-area-0.0.0.0] network 6.6.6.6 0.0.0.0
[P2-ospf-1-area-0.0.0.0] network 10.4.1.0 0.0.0.255