f
fsdb_vxfs(1M)
fsdb_vxfs(1M)
directory_block_field
= #
Set the contents of the given directory block field to the specified number. The
current block is treated as a directory block and the offset in that block which is
represented by the given field is changed. The symbols representing directory block
fields are listed above.
d#
Set the current directory entry to the specified number. The current block is treated
as a directory block. If the current block is an immediate data area for an inode, then
the block is treated as containing immediate directory entries. If it is the last com-
mand on a line, the directory entry at the resulting offset is printed.
directory_entry_field
= #
Set the contents of the given directory field to the specified number. The current
directory entry specifies where the directory entry is located. The resulting value is
printed in hexadecimal.
nm =
string
Set the directory name field of the current directory entry to the specified string. The
resulting value is printed as a character string.
calc # [+|-|
∗
|/ #]
Take a number or the sum, difference, product or dividend of two numbers and print
in decimal, octal, hexadecimal and character format.
find # B|H|W|D [#]
Search for the given numeric pattern in the file system. The size of the object to
match is specified. If a double-word is specified, then two numbers must be given.
The search is performed forward from the current offset. A maximum number of
blocks to search can be specified. If found, the location and value are printed in hexa-
decimal.
find
string
[#]
Search for the given character string in the file system. The search is performed for-
ward from the current offset.
A maximum number of blocks to search can be
specified. If found the location and string are printed.
fmtlog
Format all intent log entries. A completely formatted intent log can be quite lengthy.
It is a good idea use the
fsdb
command as a filter and redirect the output to a file or
pager to look at a complete log format.
listfset
List all filesets by their indexes and names.
mapi #
Treat the number as a logical offset in the file described by the current inode, and
print the extent that it maps to.
reset
Does the equivalent of exiting
fsdb
and restarting on same device.
Help Commands
The following help commands are supported:
h|help
Display primary help screen.
h mod
Display modification-commands help screen.
h print
Display print-commands help screen.
EXAMPLES
386i
Prints inumber 386 in an inode format. This now becomes the current working inode.
ln=4
Changes the link count for the working inode to 4.
8192B.p S
Prints the super-block of this file system symbolically.
d7.nm =
foo
Changes the name field in the directory slot to foo.
2i.a0.d7.ino = 3
Changes the inumber for the seventh directory slot in the root directory to three (also
shows how to combine several operations on one command line)
23i.im.d5
Prints the sixth directory entry in the immediate area of inode 23.
HP-UX 11i Version 2: December 2007 Update
−
7
−
Hewlett-Packard Company
305